greetd-0.8.0.ebuild 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. # Copyright 2017-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. # Auto-Generated by cargo-ebuild 0.4.0
  4. EAPI=8
  5. CRATES="
  6. arc-swap-0.4.6
  7. async-trait-0.1.31
  8. autocfg-1.0.1
  9. bitflags-1.2.1
  10. bytes-1.0.1
  11. cc-1.0.53
  12. cfg-if-0.1.10
  13. cfg-if-1.0.0
  14. enquote-1.0.3
  15. getopts-0.2.21
  16. itoa-0.4.5
  17. libc-0.2.82
  18. log-0.4.8
  19. memchr-2.3.3
  20. mio-0.7.7
  21. miow-0.3.6
  22. nix-0.19.1
  23. ntapi-0.3.4
  24. once_cell-1.5.2
  25. pam-sys-0.5.6
  26. pin-project-lite-0.2.4
  27. proc-macro2-1.0.12
  28. quote-1.0.5
  29. rpassword-5.0.0
  30. ryu-1.0.4
  31. serde-1.0.110
  32. serde_derive-1.0.110
  33. serde_json-1.0.53
  34. signal-hook-registry-1.2.0
  35. socket2-0.3.19
  36. syn-1.0.21
  37. thiserror-1.0.17
  38. thiserror-impl-1.0.17
  39. tokio-1.0.2
  40. tokio-macros-1.0.0
  41. unicode-width-0.1.7
  42. unicode-xid-0.2.0
  43. users-0.11.0
  44. winapi-0.3.8
  45. winapi-i686-pc-windows-gnu-0.4.0
  46. winapi-x86_64-pc-windows-gnu-0.4.0
  47. "
  48. inherit cargo optfeature systemd
  49. DESCRIPTION="ipc based login daemon"
  50. HOMEPAGE="https://git.sr.ht/~kennylevinsen/greetd/"
  51. SRC_URI="https://git.sr.ht/~kennylevinsen/greetd/archive/${PV}.tar.gz -> ${P}.tar.gz
  52. $(cargo_crate_uris ${CRATES})
  53. "
  54. LICENSE="Apache-2.0 BSD Boost-1.0 GPL-3 MIT Unlicense"
  55. SLOT="0"
  56. KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
  57. IUSE="man"
  58. DEPEND="
  59. acct-user/greetd
  60. sys-auth/pambase
  61. sys-libs/pam
  62. "
  63. RDEPEND="${DEPEND}"
  64. BDEPEND="man? ( app-text/scdoc )"
  65. QA_FLAGS_IGNORED="usr/bin/.*greet.*"
  66. PATCHES=(
  67. "${FILESDIR}/${PN}-0.6.1-correct_user_config_toml.patch"
  68. )
  69. src_compile() {
  70. cargo_src_compile
  71. if use man; then
  72. scdoc < ./man/agreety-1.scd > ./agreety.1 || die
  73. scdoc < ./man/greetd-1.scd > ./greetd.1 || die
  74. scdoc < ./man/greetd-5.scd > ./greetd.5 || die
  75. scdoc < ./man/greetd-ipc-7.scd > ./greetd-ipc.7 || die
  76. fi
  77. }
  78. src_install() {
  79. # if USE=debug, install binaries from the debug directory; else
  80. # install binaries from the release directory
  81. # https://bugs.gentoo.org/889052
  82. dobin target/${RUSTHOST}/$(usex debug debug release)/{agreety,fakegreet,greetd}
  83. insinto /etc/greetd
  84. doins config.toml
  85. systemd_dounit greetd.service
  86. if use man; then
  87. doman agreety.1 greetd.1 greetd.5 greetd-ipc.7
  88. fi
  89. }
  90. pkg_postint() {
  91. optfeature "eye-candy gtk based greeter" gui-apps/gtkgreet
  92. optfeature "simplistic but sleek terminal greeter" gui-apps/tuigreet
  93. }