rofi-file-browser-extended-1.3.1-r2.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake
  5. DESCRIPTION="A file browser for rofi"
  6. HOMEPAGE="https://github.com/marvinkreis/rofi-file-browser-extended"
  7. if [[ ${PV} == "9999" ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="https://github.com/marvinkreis/${PN}.git"
  10. else
  11. SRC_URI="https://github.com/marvinkreis/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  12. KEYWORDS="amd64 ~x86"
  13. fi
  14. LICENSE="MIT"
  15. SLOT="0"
  16. BDEPEND="virtual/pkgconfig"
  17. COMMON_DEPEND="
  18. dev-libs/glib:2
  19. gui-apps/rofi
  20. "
  21. DEPEND="
  22. ${COMMON_DEPEND}
  23. x11-libs/cairo
  24. "
  25. RDEPEND="${COMMON_DEPEND}"
  26. PATCHES=(
  27. # https://bugs.gentoo.org/880985 https://github.com/marvinkreis/rofi-file-browser-extended/pull/49
  28. "${FILESDIR}/${PN}-1.3.1-fix-function-pointer-initialization.patch"
  29. "${FILESDIR}/${PN}-1.3.1-fix-gcc14-build-fix.patch"
  30. )
  31. src_prepare() {
  32. # Delete the lines in CMakeLists.txt that install the man page.
  33. sed -i "45,56d" CMakeLists.txt || die
  34. cmake_src_prepare
  35. }
  36. src_install() {
  37. cmake_src_install
  38. doman "doc/${PN}.1"
  39. }