vulkan-memory-allocator-3.0.1_p20230722.ebuild 806 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake
  5. COMMIT_HASH="6eb62e1515072827db992c2befd80b71b2d04329"
  6. DESCRIPTION="Easy to integrate Vulkan memory allocation library"
  7. HOMEPAGE="https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator"
  8. SRC_URI="https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. IUSE="doc"
  13. BDEPEND="doc? ( dev-python/sphinx )"
  14. RDEPEND="media-libs/vulkan-loader"
  15. RESTRICT="mirror"
  16. S="${WORKDIR}/VulkanMemoryAllocator-${COMMIT_HASH}"
  17. CMAKE_BUILD_TYPE=Release
  18. src_configure() {
  19. local mycmakeargs=(
  20. -DVMA_BUILD_DOCUMENTATION="$(usex doc)"
  21. -DVMA_BUILD_SAMPLES=OFF
  22. )
  23. cmake_src_configure
  24. }