clipper2-1.0.4.ebuild 819 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{9..11} )
  5. inherit cmake
  6. MY_PN=${PN^}
  7. DESCRIPTION="Polygon and line clipping and offsetting library (C++, C#, Delphi)"
  8. HOMEPAGE="http://www.angusj.com/delphi/clipper.php"
  9. SRC_URI="https://github.com/AngusJohnson/${MY_PN}/archive/refs/tags/${MY_PN}_${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="Boost-1.0"
  11. SLOT="0"
  12. KEYWORDS="amd64 ~arm64 ~x86"
  13. IUSE="utils examples test"
  14. RDEPEND=""
  15. BDEPEND="app-arch/unzip"
  16. RESTRICT="mirror"
  17. S="${WORKDIR}/${MY_PN}-${MY_PN}_${PV}/CPP"
  18. src_configure() {
  19. local mycmakeargs=(
  20. -DBUILD_SHARED_LIBS=ON
  21. -DCLIPPER2_UTILS=$(usex utils ON OFF)
  22. -DCLIPPER2_TESTS=$(usex test ON OFF)
  23. -DCLIPPER2_EXAMPLES=$(usex examples ON OFF)
  24. )
  25. cmake_src_configure
  26. }