inotify-simple-1.3.5.ebuild 541 B

12345678910111213141516171819202122232425
  1. # Copyright 2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{10..12} )
  5. inherit distutils-r1
  6. MY_PN="${PN/-/_}"
  7. DESCRIPTION="Simple Python wrapper around inotify with ctypes"
  8. HOMEPAGE="https://github.com/chrisjbillington/${MY_PN}"
  9. SRC_URI="https://github.com/chrisjbillington/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="BSD-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~arm64 ~mips ~x86 ~arm"
  13. RDEPEND="${PYTHON_DEPS}
  14. "
  15. RESTRICT="test mirror"
  16. S=${WORKDIR}/${MY_PN}-${PV}