banal-1.0.6.ebuild 688 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2020 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{10,11} )
  5. inherit distutils-r1 #git-r3
  6. DESCRIPTION="Commons of banal micro-functions for Python."
  7. HOMEPAGE="https://pypi.org/project/banal http://pudo.org friedrich@pudo.org "
  8. #EGIT_REPO_URI="https://github.com/pudo/banal"
  9. #EGIT_COMMIT="528c339be5138458e387a058581cf7d261285447"
  10. SRC_URI="https://github.com/pudo/banal/archive/${PV}.tar.gz -> ${P}.tar.gz"
  11. LICENSE="MIT"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. RESTRICT="mirror"
  16. RDEPEND="
  17. >=dev-python/six-1.11.0[${PYTHON_USEDEP}]
  18. "
  19. DEPEND="${RDEPEND}
  20. dev-python/setuptools[${PYTHON_USEDEP}]
  21. "