normality-2.6.1.ebuild 905 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2023 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{10..12} )
  5. inherit distutils-r1 git-r3
  6. DESCRIPTION="A tiny library for Python text normalisation. Useful for ad-hoc text processing."
  7. HOMEPAGE="https://pypi.org/project/normality http://pudo.org friedrich@pudo.org "
  8. EGIT_REPO_URI="https://github.com/pudo/normality"
  9. EGIT_COMMIT="e23d4bd4b66254813adbc3b472919ab16a87e10b"
  10. LICENSE="MIT"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="icu test"
  14. RDEPEND="
  15. >=dev-python/six-1.11.0[${PYTHON_USEDEP}]
  16. >=dev-python/banal-0.4.1[${PYTHON_USEDEP}]
  17. dev-python/text-unidecode[${PYTHON_USEDEP}]
  18. dev-python/chardet[${PYTHON_USEDEP}]
  19. icu? ( >=dev-python/pyicu-1.9.3[${PYTHON_USEDEP}] )
  20. "
  21. DEPEND="${RDEPEND}
  22. dev-python/setuptools[${PYTHON_USEDEP}]
  23. "
  24. python_prepare_all() {
  25. rm -r "tests" || die
  26. distutils-r1_python_prepare_all
  27. }