flake.nix 907 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # This flake was initially generated by fh, the CLI for FlakeHub (version 0.1.8)
  2. {
  3. description = "slstatus";
  4. inputs = {
  5. flake-schemas.url = "https://flakehub.com/f/DeterminateSystems/flake-schemas/*.tar.gz";
  6. nixpkgs.url = "https://flakehub.com/f/NixOS/nixpkgs/*.tar.gz";
  7. };
  8. outputs = { self, flake-schemas, nixpkgs }:
  9. let
  10. supportedSystems = [ "x86_64-linux" "aarch64-linux" ];
  11. forEachSupportedSystem = f: nixpkgs.lib.genAttrs supportedSystems (system: f {
  12. pkgs = import nixpkgs { inherit system; };
  13. });
  14. in {
  15. schemas = flake-schemas.schemas;
  16. devShells = forEachSupportedSystem ({ pkgs }: {
  17. default = pkgs.mkShell {
  18. packages = with pkgs; [
  19. git
  20. nixpkgs-fmt
  21. xorg.libX11
  22. entr
  23. gnumake
  24. ];
  25. };
  26. });
  27. };
  28. }