gog.scm 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100
  1. ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
  2. ;;;
  3. ;;; This program is free software: you can redistribute it and/or modify
  4. ;;; it under the terms of the GNU General Public License as published by
  5. ;;; the Free Software Foundation, either version 3 of the License, or
  6. ;;; (at your option) any later version.
  7. ;;;
  8. ;;; This program is distributed in the hope that it will be useful,
  9. ;;; but WITHOUT ANY WARRANTY; without even the implied warranty of
  10. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  11. ;;; GNU General Public License for more details.
  12. ;;;
  13. ;;; You should have received a copy of the GNU General Public License
  14. ;;; along with this program. If not, see <https://www.gnu.org/licenses/>.
  15. (define-module (nongnu packages gog)
  16. #:use-module (gnu packages boost)
  17. #:use-module (gnu packages compression)
  18. #:use-module (gnu packages crypto)
  19. #:use-module (gnu packages curl)
  20. #:use-module (gnu packages pkg-config)
  21. #:use-module (gnu packages serialization)
  22. #:use-module (gnu packages web)
  23. #:use-module (gnu packages xml)
  24. #:use-module (guix packages)
  25. #:use-module (guix download)
  26. #:use-module (guix git-download)
  27. #:use-module (guix build-system cmake)
  28. #:use-module (guix build-system gnu)
  29. #:use-module ((guix licenses) #:prefix license:))
  30. (define-public lgogdownloader
  31. (package
  32. (name "lgogdownloader")
  33. (version "3.5")
  34. (source
  35. (origin
  36. (method git-fetch)
  37. (uri (git-reference
  38. (url "https://github.com/Sude-/lgogdownloader.git")
  39. (commit (string-append "v" version))))
  40. (file-name (git-file-name name version))
  41. (sha256
  42. (base32 "0a3rrkgqwdqxx3ghzw182jx88gzzw6ldp3jasmgnr4l7gpxkmwws"))))
  43. (build-system cmake-build-system)
  44. (arguments '(#:tests? #f)) ; no tests
  45. (inputs
  46. `(("boost" ,boost)
  47. ("curl" ,curl)
  48. ("htmlcxx" ,htmlcxx)
  49. ("jsoncpp" ,jsoncpp)
  50. ("liboauth" ,liboauth)
  51. ("rhash" ,rhash)
  52. ("tinyxml2" ,tinyxml2)
  53. ("zlib" ,zlib)))
  54. (native-inputs
  55. `(("pkg-config" ,pkg-config)))
  56. (home-page "https://sites.google.com/site/gogdownloader/")
  57. (synopsis "Downloader for GOG.com files")
  58. (description "LGOGDownloader is a client for the GOG.com download API,
  59. allowing simple downloads and updates of games and other files from GOG.com.")
  60. (license license:wtfpl2)))
  61. (define-public htmlcxx
  62. (package
  63. (name "htmlcxx")
  64. (version "0.87")
  65. (source
  66. (origin
  67. (method url-fetch)
  68. (uri
  69. (string-append "mirror://sourceforge/htmlcxx/v"
  70. version "/htmlcxx-" version ".tar.gz"))
  71. (sha256
  72. (base32 "1j3mzjlczjrk4ahc43s6kzpvzypzjmqz4sillnca5yadrwwgjf2x"))))
  73. (build-system gnu-build-system)
  74. (home-page "http://htmlcxx.sourceforge.net/")
  75. (synopsis "Simple non-validating CSS1 and HTML parser for C++")
  76. (description "htmlcxx is a simple non-validating CSS1 and HTML parser for
  77. C++. Although there are several other HTML parsers available, htmlcxx has some
  78. characteristics that make it unique:
  79. @itemize
  80. @item STL like navigation of DOM tree, using excelent's tree.hh library from
  81. Kasper Peeters
  82. @item It is possible to reproduce exactly, character by character, the original
  83. document from the parse tree
  84. @item Bundled CSS parser
  85. @item Optional parsing of attributes
  86. @item C++ code that looks like C++ (not so true anymore)
  87. @item Offsets of tags/elements in the original document are stored in the nodes
  88. of the DOM tree
  89. @end itemize
  90. The parsing politics of htmlcxx were created trying to mimic Mozilla Firefox
  91. (https://www.mozilla.org) behavior. So you should expect parse trees similar
  92. to those create by Firefox. However, differently from Firefox, htmlcxx does
  93. not insert non-existent stuff in your html. Therefore, serializing the DOM
  94. tree gives exactly the same bytes contained in the original HTML document.")
  95. (license (list license:lgpl2.0
  96. license:asl2.0))))