compression.scm 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
  3. ;;;
  4. ;;; This file is not part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (nongnu packages compression)
  19. #:use-module (guix packages)
  20. #:use-module (guix build-system gnu)
  21. #:use-module (guix download)
  22. #:use-module (nonguix licenses))
  23. (define-public unrar
  24. (package
  25. (name "unrar")
  26. (version "5.7.3")
  27. (source (origin
  28. (method url-fetch)
  29. (uri (string-append "https://www.rarlab.com/rar/unrarsrc-"
  30. version
  31. ".tar.gz"))
  32. (sha256
  33. (base32
  34. "0i5442sh18v9s47k1j8q04m3ki98z012rw7ml7c5iwklhfvmds20"))))
  35. (build-system gnu-build-system)
  36. (arguments
  37. '(#:tests? #f ; No tests.
  38. #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
  39. #:phases
  40. (modify-phases %standard-phases
  41. (delete 'configure))))
  42. (home-page "https://www.rarlab.com/rar_add.htm")
  43. (synopsis "Extract files from RAR archives")
  44. (description "The RAR decompression program. It is nonfree (as in
  45. freedom), but open-source.")
  46. (license (nonfree "https://www.win-rar.com/gtb_priv.html?&L=0"))))