PKGBUILD 677 B

12345678910111213141516171819202122232425262728293031
  1. # Maintainer: Alexander Rosenberg <zanderpkg at pm dot me>
  2. pkgname=exword_tools
  3. pkgver=1
  4. pkgrel=1
  5. pkgdesc='Cross platform implementation of TextLoader and CasioLibrary using libexword'
  6. url='https://github.com/brijohn/exword_tools'
  7. arch=('x86_64')
  8. license=('UNKNOWN')
  9. depends=('wxgtk3' 'libexword')
  10. makedepends=('autoconf' 'automake' 'git' 'make')
  11. source=('git+https://github.com/brijohn/exword_tools.git')
  12. sha256sums=('SKIP')
  13. pkgver(){
  14. cd "$pkgname"
  15. git rev-list --count HEAD
  16. }
  17. build() {
  18. cd "$pkgname"
  19. ./autogen.sh
  20. ./configure --prefix="$pkgdir/usr"
  21. }
  22. package() {
  23. cd "$pkgname"
  24. make install
  25. install -m644 -D README "$pkgdir/usr/share/doc/$pkgname/README"
  26. }