wlroots.nix 776 B

1234567891011121314151617181920212223
  1. { stdenv, fetchgit, wlroots, wayland-protocols, wayland, meson, ninja, cmake, pkgconfig, pixman, libxkbcommon, libudev, libGL, xorg }:
  2. stdenv.mkDerivation {
  3. pname = "wltrunk";
  4. version = "2019-11-27";
  5. src = fetchgit {
  6. url = "https://git.sr.ht/~bl4ckb0ne/wltrunk";
  7. rev = "5a234d3360b50764172e074ef969e40e600075c3";
  8. sha256 = "1mvgchwppi2vrj25bgng3psyr0jkbah2419lp4hyqj6drb5r0l6q";
  9. };
  10. nativeBuildInputs = [ meson ninja pkgconfig cmake ];
  11. buildInputs = [ wlroots wayland-protocols wayland pixman libxkbcommon libudev libGL xorg.libX11 ];
  12. meta = with stdenv.lib; {
  13. homepage = "https://git.sr.ht/~bl4ckb0ne/wltrunk";
  14. description = "High-level Wayland compositor library based on wlroots";
  15. license = licenses.gpl3;
  16. # maintainers =
  17. };
  18. }