python-makefile.patch 786 B

123456789101112131415161718192021
  1. #! /bin/sh /usr/share/dpatch/dpatch-run
  2. ## 02_python-makefile.dpatch by <pdm@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: Don't compile Python files. Fix path settings.
  6. @DPATCH@
  7. Index: speech-dispatcher/src/python/Makefile.in
  8. ===================================================================
  9. --- speech-dispatcher.orig/src/python/Makefile.in 2010-06-19 09:08:14.000000000 +0200
  10. +++ speech-dispatcher/src/python/Makefile.in 2010-06-19 09:55:38.000000000 +0200
  11. @@ -17,7 +17,7 @@
  12. install:
  13. if test -x /usr/bin/python; then \
  14. - ./setup.py install --prefix=${DESTDIR}${prefix}; \
  15. + ./setup.py install --no-compile --prefix=${DESTDIR}${prefix}; \
  16. else \
  17. echo "Python not found, not installing speechd module nor spd-conf"; \
  18. fi