pulse-only.patch 1.2 KB

123456789101112131415161718192021222324252627
  1. Index: speech-dispatcher/config/speechd.conf.in
  2. ===================================================================
  3. --- speech-dispatcher.orig/config/speechd.conf.in 2010-06-28 10:35:49.000000000 +0200
  4. +++ speech-dispatcher/config/speechd.conf.in 2010-06-28 10:36:53.000000000 +0200
  5. @@ -166,7 +166,7 @@
  6. # PulseAudio is a sound server for POSIX and WIN32 systems.
  7. #
  8. -# AudioOutputMethod "pulse,alsa"
  9. +# AudioOutputMethod "pulse"
  10. # What ALSA device to use when Advanced Linux Sound Architecture is
  11. # chosen for the audio output.
  12. Index: speech-dispatcher/src/server/config.c
  13. ===================================================================
  14. --- speech-dispatcher.orig/src/server/config.c 2010-06-28 10:40:14.000000000 +0200
  15. +++ speech-dispatcher/src/server/config.c 2010-06-28 10:40:29.000000000 +0200
  16. @@ -454,7 +454,7 @@
  17. /* Added by Willie Walker - default to OSS for Solaris */
  18. GlobalFDSet.audio_output_method = strdup("oss");
  19. #else
  20. - GlobalFDSet.audio_output_method = strdup("pulse,alsa");
  21. + GlobalFDSet.audio_output_method = strdup("pulse");
  22. #endif /* __SUNPRO_C */
  23. GlobalFDSet.audio_oss_device = strdup("/dev/dsp");
  24. GlobalFDSet.audio_alsa_device = strdup("default");