pulseaudio-module-xrdp-0.4.ebuild 781 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Id$
  4. EAPI=5
  5. inherit autotools eutils systemd
  6. DESCRIPTION="xrdp sink / source pulseaudio modules"
  7. HOMEPAGE="http://www.xrdp.org/"
  8. PULSE_VER="12.2"
  9. SRC_URI="
  10. https://github.com/neutrinolabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
  11. https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${PULSE_VER}.tar.xz
  12. "
  13. LICENSE="Apache-2.0"
  14. SLOT="0"
  15. KEYWORDS="~amd64 ~x86"
  16. RESTRICT="mirror"
  17. RDEPEND="
  18. net-misc/xrdp:0=
  19. >=media-sound/pulseaudio-${PULSE_VER}
  20. "
  21. src_prepare() {
  22. ./bootstrap
  23. cd ../pulseaudio-${PULSE_VER} || die
  24. ./configure
  25. }
  26. src_configure() {
  27. econf PULSE_DIR=${WORKDIR}/pulseaudio-${PULSE_VER}
  28. }
  29. src_install() {
  30. default
  31. prune_libtool_files --all
  32. }