fxsdk-9999.ebuild 797 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. DESCRIPTION="Ever wanted to develop programs for fx9860G under Linux ? GCC power, using libraries, inline assembly and C11 standard ? There you go."
  5. HOMEPAGE="https://git.planet-casio.com/lephe/fxsdk"
  6. SRC_URI="https://moriya.zapto.org/SuwakoMmh/fxsdk/archive/master.tar.gz -> ${P}.tar.gz"
  7. SLOT="0"
  8. KEYWORDS="~amd64 ~x86"
  9. IUSE=""
  10. DEPEND=""
  11. RDEPEND="${DEPEND}"
  12. BDEPEND=""
  13. S="${WORKDIR}/fxsdk/"
  14. src_install() {
  15. if [[ -f Makefile ]] || [[ -f GNUmakefile ]] || [[ -f makefile ]] ; then
  16. mkdir -p ${D}/usr/bin ${D}/usr/share/fxsdk
  17. echo target_bin=${D}/usr/bin >> Makefile.cfg
  18. echo target_data=${D}/usr/share/fxsdk >> Makefile.cfg
  19. emake DESTDIR="${D}" install
  20. fi
  21. einstalldocs
  22. }