PKGBUILD 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # U-Boot: Beaglebone and Beaglebone Black
  2. # Maintainer (archarm): Kevin Mihelich <kevin@archlinuxarm.org>
  3. # Maintainer: Andreas Grapentin <oaken-source@parabola.nu>
  4. # Contributor: André Silva <emulatorman@hyperbola.info>
  5. buildarch=4
  6. pkgname=uboot-am335x_bone
  7. pkgver=2017.07
  8. pkgrel=1
  9. pkgdesc="U-Boot for Beaglebone and Beaglebone Black"
  10. arch=('armv7h')
  11. url="http://git.denx.de/u-boot.git/"
  12. makedepends=('bc' 'git')
  13. conflicts=(uboot4{extlinux,grub}-am335x_bone)
  14. license=('GPL')
  15. install=${pkgname}.install
  16. backup=('boot/boot.txt' 'boot/boot.scr')
  17. source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
  18. '0001-parabola-arm-modifications.patch'
  19. 'boot.txt'
  20. 'mkscr')
  21. md5sums=('b74741e7a9ad1cf9a5bfa87302b80f2b'
  22. '89c046a7858da6ea55404c3b8314c41d'
  23. 'e35840bf487af832b84b41b931e16aa1'
  24. '021623a04afd29ac3f368977140cfbfd')
  25. prepare() {
  26. cd u-boot-${pkgver/rc/-rc}
  27. git apply ../0001-parabola-arm-modifications.patch
  28. }
  29. build() {
  30. cd u-boot-${pkgver/rc/-rc}
  31. unset CFLAGS CXXFLAGS LDFLAGS
  32. make distclean
  33. make am335x_boneblack_defconfig
  34. echo 'CONFIG_IDENT_STRING=" Parabola GNU/Linux-libre"' >> .config
  35. make EXTRAVERSION=-${pkgrel}
  36. }
  37. package() {
  38. cd u-boot-${pkgver/rc/-rc}
  39. mkdir -p "${pkgdir}"/boot
  40. cp MLO u-boot.img "${pkgdir}"/boot
  41. tools/mkimage -A arm -O linux -T script -C none -n "U-Boot boot script" -d ../boot.txt "${pkgdir}"/boot/boot.scr
  42. cp ../{boot.txt,mkscr} "${pkgdir}"/boot
  43. }