PKGBUILD 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Maintainer (Arch): Sven-Hendrik Haase <svenstaro@gmail.com>
  2. # Contributor (Arch): Alexander Suhoverhov <cy at ngs dot ru>
  3. # This package is in Parabola only for architectures that don't have xonotic in
  4. # their feed. Here is the status of xonotic in the various upstream
  5. # GNU/Linux distributions Parabola is based on:
  6. # +--------------+----------------+---------------+
  7. # | Architecture | Upstream | Upstream repo |
  8. # +--------------+----------------+---------------+
  9. # | armv7h | Arch Linux ARM | None |
  10. # | i686 | Arch Linux 32 | community |
  11. # | x86_64 | Arch Linux | community |
  12. # +--------------+----------------+---------------+
  13. pkgname=xonotic-data
  14. pkgver=0.8.2
  15. pkgrel=3
  16. pkgdesc="A free, fast-paced crossplatform first-person shooter (data files)"
  17. arch=('armv7h')
  18. url="http://xonotic.org"
  19. license=('GPL')
  20. depends=('bash' 'perl')
  21. makedepends=('unzip')
  22. source=("https://dl.xonotic.org/xonotic-${pkgver}.zip")
  23. sha512sums=('0787fcf326827ae0292e5917c7ff2c7fd79947209d4b62e7f83b8b828bec15b575da304e0631f9f163c9b0bd93bed13616e142398ff08cbdaaea890a939dfca5')
  24. package() {
  25. cd Xonotic
  26. # data
  27. mkdir -p "$pkgdir"/usr/share/xonotic/
  28. mv data "$pkgdir"/usr/share/xonotic/
  29. # server stuff
  30. cp -r server "$pkgdir"/usr/share/xonotic/
  31. # key
  32. install -Dm644 key_0.d0pk "$pkgdir"/usr/share/xonotic/key_0.d0pk
  33. }
  34. # vim: ts=2:sw=2 et: