123456789101112131415161718192021222324252627282930313233343536373839 |
- # Maintainer (Arch): Sven-Hendrik Haase <svenstaro@gmail.com>
- # Contributor (Arch): Alexander Suhoverhov <cy at ngs dot ru>
- # This package is in Parabola only for architectures that don't have xonotic in
- # their feed. Here is the status of xonotic in the various upstream
- # GNU/Linux distributions Parabola is based on:
- # +--------------+----------------+---------------+
- # | Architecture | Upstream | Upstream repo |
- # +--------------+----------------+---------------+
- # | armv7h | Arch Linux ARM | None |
- # | i686 | Arch Linux 32 | community |
- # | x86_64 | Arch Linux | community |
- # +--------------+----------------+---------------+
- pkgname=xonotic-data
- pkgver=0.8.2
- pkgrel=3
- pkgdesc="A free, fast-paced crossplatform first-person shooter (data files)"
- arch=('armv7h')
- url="http://xonotic.org"
- license=('GPL')
- depends=('bash' 'perl')
- makedepends=('unzip')
- source=("https://dl.xonotic.org/xonotic-${pkgver}.zip")
- sha512sums=('0787fcf326827ae0292e5917c7ff2c7fd79947209d4b62e7f83b8b828bec15b575da304e0631f9f163c9b0bd93bed13616e142398ff08cbdaaea890a939dfca5')
- package() {
- cd Xonotic
- # data
- mkdir -p "$pkgdir"/usr/share/xonotic/
- mv data "$pkgdir"/usr/share/xonotic/
- # server stuff
- cp -r server "$pkgdir"/usr/share/xonotic/
- # key
- install -Dm644 key_0.d0pk "$pkgdir"/usr/share/xonotic/key_0.d0pk
- }
- # vim: ts=2:sw=2 et:
|