PKGBUILD 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Contributor: Márcio Silva <coadde@hyperbola.info>
  2. pkgname='ucsniff-ace'
  3. pkgver='1.10'
  4. pkgrel=5
  5. pkgdesc='A simple yet powerful VoIP Corporate Directory enumeration tool that mimics the behavior of an IP Phone in order to download the name and extension entries that a given phone can display on its screen interface.'
  6. url='http://ucsniff.sourceforge.net/ace.html'
  7. license=('GPL')
  8. makedepends=('libtirpc')
  9. depends=('libpcap')
  10. arch=('i686' 'x86_64' 'armv7h')
  11. source=("http://downloads.sourceforge.net/ucsniff/ace-$pkgver.tar.gz")
  12. sha1sums=('747aee37f74e71101317809797cdaed7077dd29e')
  13. prepare() {
  14. cd "$srcdir/ace-$pkgver"
  15. # FTBS with GCC10; because '-fno-common' is now the default
  16. # this software appears to be unmaintained
  17. export CFLAGS="${CFLAGS} -fcommon -I/usr/include/tirpc"
  18. sed -i 's#linux/if_tr.h#netinet/if_tr.h#' client.h
  19. sed -i "s:gcc :gcc $CFLAGS :g" Makefile
  20. }
  21. build() {
  22. cd "$srcdir/ace-$pkgver"
  23. make
  24. }
  25. package() {
  26. cd "$srcdir/ace-$pkgver"
  27. install -Dm755 ace "$pkgdir/usr/bin/ace"
  28. }