PKGBUILD 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Maintainer (Arch): Anton Shestakov <engored*ya.ru>
  2. pkgname=supermodel
  3. pkgver=0.2a
  4. pkgrel=2
  5. pkgdesc='A Sega Model 3 Arcade Emulator'
  6. arch=('i686' 'x86_64')
  7. url='http://www.supermodel3.com/'
  8. license=('GPL3')
  9. depends=('mesa' 'glu' 'sdl' 'zlib')
  10. install=supermodel.install
  11. options=(!buildflags)
  12. source=('multiuser.patch' 'supermodel.sh'
  13. "http://www.supermodel3.com/Files/Supermodel_${pkgver}_Src.zip")
  14. sha256sums=('d8bb5c2ac4493406aefd12f2600034d1f58378cbfc82d8b3822d7f7b423bd8db'
  15. 'b7afd56a1a33bb1d231a3d6274f2e00a6b41a7d5197101e1a6f3f7d0c5c4c5a4'
  16. 'ecaf3e7fc466593e02cbf824b722587d295a7189654acb8206ce433dcff5497b')
  17. build() {
  18. cd "$srcdir/Supermodel_${pkgver}_Src"
  19. CFLAGS="$CFLAGS -Wno-narrowing"
  20. sed -i "s#-Wall -O3#$CFLAGS#" 'Makefiles/Makefile.SDL.UNIX.GCC'
  21. patch -p1 < ../multiuser.patch
  22. make -j1 -f 'Makefiles/Makefile.SDL.UNIX.GCC'
  23. }
  24. package() {
  25. cd "$srcdir/Supermodel_${pkgver}_Src"
  26. install -Dm755 "$srcdir/supermodel.sh" "$pkgdir/usr/bin/supermodel"
  27. install -Dm755 "bin/Supermodel" "$pkgdir/usr/share/supermodel/Supermodel"
  28. install -Dm644 "Docs/LICENSE.txt" "$pkgdir/usr/share/licenses/supermodel/LICENSE"
  29. install -Dm644 "Docs/README.txt" "$pkgdir/usr/share/doc/supermodel/README"
  30. install -d "$pkgdir/usr/share/supermodel/Config"
  31. install -m644 Config/* "$pkgdir/usr/share/supermodel/Config/"
  32. }