PKGBUILD 693 B

123456789101112131415161718192021222324
  1. #Maintainer (AUR): Thibaud Kehler <thibaud.kehler at gmx dot net>
  2. pkgname='python-humblewx'
  3. _module='humblewx'
  4. pkgver='0.2.1'
  5. pkgrel=1
  6. pkgdesc="Library that simplifies creating user interfaces with wxPython."
  7. license=('GPL3')
  8. url="https://github.com/thetimelineproj/humblewx"
  9. arch=('any')
  10. depends=('python')
  11. makedepends=('python-setuptools')
  12. source=("https://files.pythonhosted.org/packages/source/h/${_module}/${_module}-${pkgver}.tar.gz")
  13. md5sums=('1d3b30936aecf7570565a73878ed7f73')
  14. build() {
  15. cd "${srcdir}/${_module}-${pkgver}"
  16. python setup.py build
  17. }
  18. package() {
  19. cd "${srcdir}/${_module}-${pkgver}"
  20. python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
  21. }