PKGBUILD 973 B

1234567891011121314151617181920212223242526272829303132
  1. # Contributor (Arch): drrossum <d.r.vanrossum at gmx.de>
  2. # Contributor (Arch): sh0 <mee@sh0.org>
  3. # Maintainer : Aurélien Desbrières <aurelien@xload.io>
  4. pkgname=pdsh
  5. pkgver=2.33
  6. pkgrel=1
  7. pkgdesc='Parallel Distributed Shell'
  8. url='https://github.com/chaos/pdsh/'
  9. arch=('i686' 'x86_64' 'armv7h')
  10. license=('GPL')
  11. depends=('glibc' 'openssh' 'readline')
  12. optdepends=('perl: required by the dshbak utility')
  13. options=('libtool')
  14. source=("https://github.com/chaos/{$pkgname}/releases/download/{$pkgname}-{$pkgver}/{$pkgname}-${pkgver}.tar.gz")
  15. sha256sums=('7368087429d6269f0a6313c406ef38c6a6a947bc003ca7368fc6481b139d942f')
  16. build() {
  17. cd "${srcdir}/${pkgname}-${pkgver}"
  18. ./configure --prefix=/usr --mandir=/usr/share/man \
  19. --without-rsh \
  20. --with-ssh \
  21. --with-dshgroups \
  22. --with-readline || return 1
  23. make || return 1
  24. }
  25. package() {
  26. cd "${srcdir}/${pkgname}-${pkgver}"
  27. make DESTDIR="${pkgdir}/" install || return 1
  28. }