PKGBUILD 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright (C) 2020 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
  2. # This program is free software: you can redistribute it and/or modify
  3. # it under the terms of the GNU General Public License as published by
  4. # the Free Software Foundation, either version 3 of the License, or
  5. # (at your option) any later version.
  6. # Parabola changes and rationale:
  7. # no changes.
  8. pkgname=omap-usb-boot
  9. pkgver=0.1
  10. pkgrel=1
  11. pkgdesc="Tool to communicate with OMAP bootroms to execute code, change boot media, etc"
  12. arch=('armv7h' 'i686' 'x86_64')
  13. url='https://git.replicant.us/contrib/PaulK/omap-usb-boot/'
  14. license=('GPL3')
  15. depends=('libusb')
  16. makedepends=('git')
  17. _commit=('15ea4dcaecdf2e65a79d78a3fd4fd500addfc7cc')
  18. source=("git://git.replicant.us/PaulK/omap-usb-boot#commit=${_commit}")
  19. sha256sums=('SKIP')
  20. prepare() {
  21. cd "$srcdir/$pkgname"
  22. ./autogen.sh
  23. }
  24. build() {
  25. cd "$srcdir/$pkgname"
  26. ./configure --prefix=/usr --mandir=/usr/share/man
  27. make
  28. }
  29. package(){
  30. cd "$srcdir/$pkgname"
  31. make DESTDIR="$pkgdir" install
  32. install -D -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
  33. }