PKGBUILD 992 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Maintainer (AUR): Baptiste Jonglez <baptiste--aur at jonglez dot org>
  2. # Maintainer : Aurélien DESBRIÈRES <aurelien@hackers.camp>
  3. # parabola changes and rationale:
  4. # no changes.
  5. pkgname=egypt
  6. pkgver=1.10
  7. pkgrel=2.1
  8. pkgdesc="A simple tool for creating call graphs of C programs"
  9. arch=("any")
  10. url="http://www.gson.org/egypt/"
  11. # The author states: "This program is free software; you can redistribute
  12. # it and/or modify it under the same terms as Perl itself."
  13. license=('GPL' 'PerlArtistic')
  14. depends=("perl" "gcc" "graphviz")
  15. makedepends=("perl")
  16. optdepends=("gcc: for generating an intermediate representation of C code (RTL files)"
  17. "graphviz: for visualising the resulting graph")
  18. source=("https://www.gson.org/egypt/download/$pkgname-$pkgver.tar.gz")
  19. md5sums=('591dce680bef60e73edccd0220957846')
  20. build() {
  21. cd "$srcdir/$pkgname-$pkgver"
  22. perl Makefile.PL
  23. make
  24. }
  25. package() {
  26. cd "$srcdir/$pkgname-$pkgver"
  27. make DESTDIR="$pkgdir/" install
  28. }
  29. # vim:set ts=2 sw=2 et: