PKGBUILD 959 B

1234567891011121314151617181920212223242526272829303132
  1. # Maintainer (Arch): Bernhard Landauer <oberon@manjaro.org>
  2. # Contributor (Arch): Matthias Maennich <arch@maennich.net>
  3. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  4. # Contributor: Luke Shumaker <lukeshu@parabola.nu>
  5. pkgname=command-not-found
  6. pkgver=0.6.2
  7. pkgrel=2
  8. pkgdesc="In case a command could not be found this utility searches for packages containing this or a similar command (bash,zsh)."
  9. arch=('armv7h' 'i686' 'x86_64')
  10. url="https://github.com/metti/command-not-found"
  11. license=('GPL3')
  12. depends=('boost-libs' 'libarchive' 'tdb' 'wget')
  13. makedepends=('boost' 'cmake' 'git')
  14. install=$pkgname.install
  15. source=(https://github.com/metti/command-not-found/archive/v$pkgver.tar.gz)
  16. sha256sums=('a5946d2180b67ff16f0cd4d248dce3fcee36cbf535b946e50c90c55dc6cf31aa')
  17. build() {
  18. cd $pkgname-$pkgver
  19. cmake \
  20. -DCMAKE_BUILD_TYPE=Release \
  21. -DCMAKE_INSTALL_PREFIX="" \
  22. src
  23. make
  24. }
  25. package(){
  26. cd $pkgname-$pkgver
  27. make DESTDIR="$pkgdir" install
  28. }