1234567891011121314151617181920212223242526272829303132 |
- # Maintainer (Arch): Bernhard Landauer <oberon@manjaro.org>
- # Contributor (Arch): Matthias Maennich <arch@maennich.net>
- # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
- # Contributor: Luke Shumaker <lukeshu@parabola.nu>
- pkgname=command-not-found
- pkgver=0.6.2
- pkgrel=2
- pkgdesc="In case a command could not be found this utility searches for packages containing this or a similar command (bash,zsh)."
- arch=('armv7h' 'i686' 'x86_64')
- url="https://github.com/metti/command-not-found"
- license=('GPL3')
- depends=('boost-libs' 'libarchive' 'tdb' 'wget')
- makedepends=('boost' 'cmake' 'git')
- install=$pkgname.install
- source=(https://github.com/metti/command-not-found/archive/v$pkgver.tar.gz)
- sha256sums=('a5946d2180b67ff16f0cd4d248dce3fcee36cbf535b946e50c90c55dc6cf31aa')
- build() {
- cd $pkgname-$pkgver
- cmake \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="" \
- src
- make
- }
- package(){
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
- }
|