1234567891011121314151617181920212223242526 |
- # Maintainer (AUR): Yuexuan Gu <lastavengers@outlook.com>
- # Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
- # parabola changes and rationale:
- # - added manpage to package
- pkgname=cinclude2dot
- pkgver=1.1
- pkgrel=2.1
- pkgdesc="a perl script which analyses C/C++ code and produces a #include dependency graph."
- url="https://www.flourish.org/cinclude2dot/"
- arch=('any')
- license=('GPL')
- depends=('perl')
- optdepends=('graphviz: convert dot file to png file.')
- source=('https://www.flourish.org/cinclude2dot/cinclude2dot'
- 'https://www.flourish.org/cinclude2dot/cinclude2dot.1')
- sha256sums=('78f2e60d49882c7d0969a2ac396238234d7b8d16eef83cc2910e6556fd6b990c'
- '28a797b7a9c23d41de949ec3d07d0c04a8648bf75b8325890c5158acb6925cb5')
- package() {
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
- gzip -c $pkgname.1 > $pkgname.1.gz
- install -Dm644 $pkgname.1.gz "$pkgdir/usr/share/man/man1/$pkgname.1.gz"
- }
|