PKGBUILD 928 B

1234567891011121314151617181920212223242526
  1. # Maintainer (AUR): Yuexuan Gu <lastavengers@outlook.com>
  2. # Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
  3. # parabola changes and rationale:
  4. # - added manpage to package
  5. pkgname=cinclude2dot
  6. pkgver=1.1
  7. pkgrel=2.1
  8. pkgdesc="a perl script which analyses C/C++ code and produces a #include dependency graph."
  9. url="https://www.flourish.org/cinclude2dot/"
  10. arch=('any')
  11. license=('GPL')
  12. depends=('perl')
  13. optdepends=('graphviz: convert dot file to png file.')
  14. source=('https://www.flourish.org/cinclude2dot/cinclude2dot'
  15. 'https://www.flourish.org/cinclude2dot/cinclude2dot.1')
  16. sha256sums=('78f2e60d49882c7d0969a2ac396238234d7b8d16eef83cc2910e6556fd6b990c'
  17. '28a797b7a9c23d41de949ec3d07d0c04a8648bf75b8325890c5158acb6925cb5')
  18. package() {
  19. install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
  20. gzip -c $pkgname.1 > $pkgname.1.gz
  21. install -Dm644 $pkgname.1.gz "$pkgdir/usr/share/man/man1/$pkgname.1.gz"
  22. }