PKGBUILD 892 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Maintainer (AUR): Valère Monseur <valere dot monseur@ymail dot com>
  2. # parabola changes and rationale:
  3. # - added install file for icon cache and desktop database maintenance
  4. pkgname=awf-git
  5. _pkgname=awf
  6. pkgver=v1.4.0.r0.gc937f1b
  7. pkgrel=1
  8. pkgdesc='A theme preview application for gtk2 and gtk3'
  9. arch=('i686' 'x86_64' 'armv7h')
  10. url='https://github.com/valr/awf'
  11. license=('GPL')
  12. depends=('gtk2' 'gtk3' 'hicolor-icon-theme')
  13. makedepends=('git')
  14. source=("$pkgname"::'git+https://github.com/valr/awf.git')
  15. md5sums=('SKIP')
  16. install=awf.install
  17. pkgver() {
  18. cd "${srcdir}/${pkgname}"
  19. git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
  20. }
  21. build() {
  22. cd "${srcdir}/${pkgname}"
  23. ./autogen.sh
  24. ./configure --prefix=/usr
  25. make
  26. }
  27. package() {
  28. cd "${srcdir}/${pkgname}"
  29. make DESTDIR="${pkgdir}" install
  30. install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/COPYING"
  31. }