PKGBUILD 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879
  1. # Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
  2. # Contributor: Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
  3. # Contributor: fauno <fauno@kiwwwi.com.ar>
  4. # Contributor: Márcio Silva <coadde@hyperbola.info>
  5. pkgname=libretools
  6. pkgver=20181004
  7. pkgrel=6.1
  8. pkgrel+=.nonsystemd2
  9. pkgdesc="Programs for Parabola development"
  10. arch=('any')
  11. url="https://git.parabola.nu/packages/libretools.git/"
  12. license=('GPL3' 'GPL2')
  13. backup=(etc/libretools.conf
  14. etc/libretools.d/chroot.conf
  15. etc/libretools.d/libredbdiff.conf
  16. etc/libretools.d/librefetch.conf)
  17. install=libretools.install
  18. conflicts=(devtools libretools-mips64el)
  19. replaces=(libretools-mips64el)
  20. depends=(
  21. "librelib=$pkgver"
  22. "gitget=$pkgver" # `createworkdir`
  23. 'pacman>=5.1.1-1.parabola5' 'pacman<5.3'
  24. arch-install-scripts # `mkarchroot` uses `pacstrap`
  25. binutils # `libremakepkg` uses `makepkg` uses `strip`
  26. expac # `libredbdiff`
  27. fakeroot # `libremakepkg` uses `makepkg` uses `fakeroot`
  28. make # `librefetch`
  29. openssh # `librerelease`
  30. rsync # `librerelease` and `makechrootpkg.sh`
  31. chroot-nspawn # chroot-nspawn
  32. tokyocabinet # `toru`
  33. #namcap # Namcap is currently dissabled in libremakepkg :-(
  34. subversion # `diff-unfree`
  35. wget # `aur`, optdepend for librelib:`blacklist`
  36. )
  37. optdepends=('qemu-user-static-binfmt: To build ARM packages from x86')
  38. makedepends=(ruby-ronn)
  39. checkdepends=(
  40. bash-bats git
  41. 'pacman>=5.1.1-1.parabola5' 'pacman<5.3'
  42. expac
  43. openssh
  44. rsync
  45. tokyocabinet
  46. )
  47. source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz{,.sig}
  48. nonsystemd.patch
  49. 0002-libremakepkg-pacman_5_2.patch)
  50. sha256sums=('2bdefd1803ba3e6cbd1eb955fad3de9ce8a4abfd23a0bd96a60772762df7b53b'
  51. 'SKIP'
  52. '511de3404afcb3fe2ed002a94be00bc0b83d6abeb1cf3ab0456bf916c8f1114e'
  53. '8986adf14a81b979b2ff4c4e3e76483115c146782e4ba30640649299f98355df')
  54. validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9') # Luke Shumaker
  55. prepare() {
  56. cd "$srcdir/$pkgbase-$pkgver"
  57. # non-systemd patch changes:
  58. # * uses chroot-nspawn instead of systemd-nspawn
  59. # * replaces systemd-machine-id-setup with dbus-uuidgen
  60. patch -p1 -i ../nonsystemd.patch
  61. # don't apply 0001-libremakepkg-rw-startdir.patch like libre/libretools because
  62. # by using chroot-nspawn we don't have that issue
  63. patch -N -p1 -i $srcdir/0002-libremakepkg-pacman_5_2.patch
  64. }
  65. build() {
  66. cd "$srcdir/$pkgbase-$pkgver"
  67. make
  68. }
  69. package() {
  70. cd "$srcdir/$pkgbase-$pkgver"
  71. make install-libretools DESTDIR="$pkgdir"
  72. }