PKGBUILD 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # $Id$
  2. # Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
  3. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  4. # Contributor: André Silva <emulatorman@hyperbola.info>
  5. # parabola changes and rationale:
  6. # - removed libgdata support
  7. pkgname=grilo-plugins
  8. pkgver=0.3.5
  9. pkgrel=1.nonprism1
  10. pkgdesc="A collection of plugins for the Grilo framework, without libgdata support"
  11. url="https://git.gnome.org/browse/grilo-plugins"
  12. arch=(x86_64 i686 armv7h)
  13. license=(LGPL)
  14. depends=(grilo lua libmediaart tracker gom libdmapsharing chromaprint gst-plugins-bad
  15. gmime3)
  16. makedepends=(git meson gperf)
  17. checkdepends=(gst-plugins-good gst-plugins-base)
  18. optdepends=('dleyna-server: DLNA plugin'
  19. 'tracker-miners: Tracker plugin')
  20. groups=(gnome)
  21. _commit=ec1c807ae0a3d1f2f5ca12c3147e053d1f0bddd1 # tags/grilo-plugins-0.3.5^0
  22. source=("git+https://git.gnome.org/browse/grilo-plugins#commit=$_commit"
  23. luafiles.diff)
  24. sha256sums=('SKIP'
  25. '73b388d9564ae8c1d3f464831082acffd46b35bdc85a3a8bdb25f408f9c6dc48')
  26. pkgver() {
  27. cd $pkgname
  28. git describe --tags | sed 's/^grilo-plugins-//;s/-/+/g'
  29. }
  30. prepare() {
  31. mkdir build
  32. cd $pkgname
  33. patch -Np1 -i ../luafiles.diff
  34. }
  35. build() {
  36. cd build
  37. export LANG=en_US.UTF-8
  38. meson setup --prefix=/usr --buildtype=release ../$pkgname
  39. ninja
  40. }
  41. check() {
  42. cd build
  43. # Unreliable tests using websites...
  44. meson test || :
  45. }
  46. package() {
  47. cd build
  48. DESTDIR="$pkgdir" ninja install
  49. }