12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758 |
- # Maintainer (arch): Felix Yan <felixonmars@archlinux.org>
- # Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
- # Contributor: Andrea Scarpino <andrea@archlinux.org>
- # Maintainer: Andreas Grapentin <andreas@grapentin.org>
- # Contributor: André Silva <emulatorman@hyperbola.info>
- # Contributor: jc_gargma <jc_gargma@iserlohn-fortress.net>
- # parabola changes and rationale:
- # - disable DRM
- # - replace non-free optdepends
- pkgname=okular
- pkgver=20.12.3
- pkgrel=1
- pkgrel+=.parabola1
- pkgdesc='Document Viewer'
- pkgdesc+=', with copy-protection anti-feature disabled, without nonfree recommendations'
- arch=(x86_64)
- arch+=(i686 armv7h)
- url="https://kde.org/applications/graphics/okular/"
- license=(GPL LGPL FDL)
- groups=(kde-applications kde-graphics)
- depends=(djvulibre libspectre libkexiv2 poppler-qt5 kpty kactivities threadweaver kjs kparts purpose discount phonon-qt5)
- makedepends=(extra-cmake-modules ebook-tools kdegraphics-mobipocket kdoctools khtml chmlib)
- optdepends=('ebook-tools: mobi and epub support'
- 'kdegraphics-mobipocket: mobi support' 'libzip: CHM support'
- 'khtml: CHM support' 'chmlib: CHM support' 'calligra: ODT and ODP support'
- 'unarchiver: Comic Book Archive support')
- source=("https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
- source+=(disable-drm.patch)
- sha256sums=('ae570fcd2b35cc9c061c1c55b6f8de256358f0f5dd8d0a8283f13eae006b73dc'
- 'SKIP')
- sha256sums+=('83cf760b3ae6e03d49e02369375dae3ecc05a6800d512dd9ffeaac1648c19457')
- validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
- F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
- D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
- options=(!zipman)
- prepare() {
- mkdir -p build
- cd $pkgname-$pkgver
- echo "applying disable-drm.patch"
- patch -Np1 -i "$srcdir"/disable-drm.patch
- }
- build() {
- cmake -B build -S $pkgname-$pkgver \
- -DBUILD_TESTING=OFF
- cmake --build build
- }
- package() {
- DESTDIR="$pkgdir" cmake --install build
- }
|