PKGBUILD 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Maintainer (arch): Felix Yan <felixonmars@archlinux.org>
  2. # Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
  3. # Contributor: Andrea Scarpino <andrea@archlinux.org>
  4. # Maintainer: Andreas Grapentin <andreas@grapentin.org>
  5. # Contributor: André Silva <emulatorman@hyperbola.info>
  6. # Contributor: jc_gargma <jc_gargma@iserlohn-fortress.net>
  7. # parabola changes and rationale:
  8. # - disable DRM
  9. # - replace non-free optdepends
  10. pkgname=okular
  11. pkgver=20.12.3
  12. pkgrel=1
  13. pkgrel+=.parabola1
  14. pkgdesc='Document Viewer'
  15. pkgdesc+=', with copy-protection anti-feature disabled, without nonfree recommendations'
  16. arch=(x86_64)
  17. arch+=(i686 armv7h)
  18. url="https://kde.org/applications/graphics/okular/"
  19. license=(GPL LGPL FDL)
  20. groups=(kde-applications kde-graphics)
  21. depends=(djvulibre libspectre libkexiv2 poppler-qt5 kpty kactivities threadweaver kjs kparts purpose discount phonon-qt5)
  22. makedepends=(extra-cmake-modules ebook-tools kdegraphics-mobipocket kdoctools khtml chmlib)
  23. optdepends=('ebook-tools: mobi and epub support'
  24. 'kdegraphics-mobipocket: mobi support' 'libzip: CHM support'
  25. 'khtml: CHM support' 'chmlib: CHM support' 'calligra: ODT and ODP support'
  26. 'unarchiver: Comic Book Archive support')
  27. source=("https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
  28. source+=(disable-drm.patch)
  29. sha256sums=('ae570fcd2b35cc9c061c1c55b6f8de256358f0f5dd8d0a8283f13eae006b73dc'
  30. 'SKIP')
  31. sha256sums+=('83cf760b3ae6e03d49e02369375dae3ecc05a6800d512dd9ffeaac1648c19457')
  32. validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
  33. F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
  34. D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
  35. options=(!zipman)
  36. prepare() {
  37. mkdir -p build
  38. cd $pkgname-$pkgver
  39. echo "applying disable-drm.patch"
  40. patch -Np1 -i "$srcdir"/disable-drm.patch
  41. }
  42. build() {
  43. cmake -B build -S $pkgname-$pkgver \
  44. -DBUILD_TESTING=OFF
  45. cmake --build build
  46. }
  47. package() {
  48. DESTDIR="$pkgdir" cmake --install build
  49. }