PKGBUILD 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # $Id$
  2. # Maintainer (Arch): Antonio Rojas <arojas@archlinux.org>
  3. # Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
  4. # Contributor (Arch): Giovanni Scafora <giovanni@archlinux.org>
  5. pkgname=kdevelop
  6. pkgver=5.3.2
  7. _clangver=8.0.0
  8. pkgrel=1.parabola2
  9. pkgdesc='C++ IDE using KDE technologies, without qt5-webengine dependency'
  10. arch=(x86_64 i686 armv7h)
  11. url='http://www.kdevelop.org/'
  12. license=(GPL)
  13. depends=(clang=$_clangver libksysguard kitemmodels knotifyconfig ktexteditor grantlee libkomparediff2 qt5-webkit
  14. kcmutils threadweaver knewstuff)
  15. makedepends=(extra-cmake-modules kdoctools kdevelop-pg-qt llvm qt5-tools plasma-framework krunner okteta python mesa
  16. boost purpose subversion)
  17. optdepends=('konsole: embedded terminal'
  18. 'git: Git support' 'subversion: SVN support' 'cvs: CVS support'
  19. 'gdb: GNU debugger support' 'lldb: LLDB debugger support'
  20. 'qt5-doc: Qt documentation integration'
  21. 'cmake: cmake integration'
  22. 'qt5-tools: qthelp plugin'
  23. 'okteta: GNU debugger support'
  24. 'plasma-framework: for the plasma addons'
  25. 'purpose: patch review plugin'
  26. 'cppcheck: code analyzer' 'heaptrack: memory profiler'
  27. 'kdevelop-clang-tidy: clang-tidy analyzer plugin' 'clazy: clazy analyzer plugin')
  28. conflicts=(kdevelop-qmljs kdevplatform)
  29. replaces=(kdevelop-qmljs kdevplatform)
  30. source=("https://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.asc})
  31. sha256sums=('08ccd575514187dcbd01ac976a619803410c26bdfabf5d2d5fd52c95b76d6f2a'
  32. 'SKIP')
  33. validpgpkeys=('329FD02C5AA48FCC77A4BBF0AC44AC6DB29779E6' # Sven Brauch <mail@svenbrauch.de>
  34. '364EFA5F639572907D392999C64CF56B13CACE5D') # Kevin Funk <kfunk@kde.org>
  35. prepare() {
  36. mkdir -p build
  37. }
  38. build() {
  39. cd build
  40. cmake ../$pkgname-$pkgver \
  41. -DCMAKE_INSTALL_PREFIX=/usr \
  42. -DCMAKE_INSTALL_LIBDIR=lib \
  43. -DCMAKE_BUILD_TYPE=Release \
  44. # -DBUILD_TESTING=OFF #turrned off because [extra/umbrello] needs libKDevPlatformTests.so.xx
  45. make
  46. }
  47. package() {
  48. cd build
  49. make DESTDIR="$pkgdir" install
  50. }