PKGBUILD 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Maintainer (Arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
  2. # Contributor (Arch): Jan de Groot <jgc@archlinux.org>
  3. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  4. # Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
  5. # Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
  6. # Contributor (Hyperbola): Márcio Silva <coadde@hyperbola.info>
  7. # parabola changes and rationale:
  8. # - rebranded to parabola
  9. # - switched default searchengine to duckduckgo
  10. # - removed useless dependency on icu because it's not
  11. # used at runtime according to readelf -d
  12. pkgname=epiphany
  13. pkgver=40.0
  14. pkgrel=1
  15. pkgrel+=.parabola2
  16. pkgdesc="A GNOME web browser based on the WebKit rendering engine"
  17. pkgdesc+=", with DuckDuckGo-HTML search"
  18. url="https://wiki.gnome.org/Apps/Web"
  19. arch=(x86_64)
  20. arch+=(i686 armv7h)
  21. license=(GPL)
  22. depends=(webkit2gtk gcr icu libdazzle libhandy libportal libarchive)
  23. depends=( $( sed 's| icu | |' <<<${depends[@]} ) )
  24. depends+=(libhogweed.so)
  25. makedepends=(docbook-xml startup-notification lsb-release gobject-introspection
  26. yelp-tools git meson)
  27. checkdepends=(xorg-server-xvfb aspell hspell hunspell nuspell libvoikko)
  28. groups=(gnome)
  29. _commit=92e808f19f8d9d21cf78938fd916572761601401 # tags/40.0^0
  30. source=("git+https://gitlab.gnome.org/GNOME/epiphany.git#commit=$_commit")
  31. source+=(libre.patch)
  32. sha256sums=('SKIP'
  33. '2ef991ade98fbe9a3a6cd80220d3348e69007abff5141bea42bbdf1c72836689')
  34. # check() requires networking
  35. _run_check=1
  36. pkgver() {
  37. cd $pkgname
  38. git describe --tags | sed 's/-/+/g'
  39. }
  40. prepare() {
  41. cd $pkgname
  42. patch -Np1 -i ../libre.patch
  43. }
  44. build() {
  45. arch-meson $pkgname build
  46. meson compile -C build
  47. }
  48. check() {
  49. (( _run_check )) || ! echo "skipping check()" || return 0
  50. dbus-run-session xvfb-run \
  51. -s '-screen 0 1920x1080x24 -nolisten local' \
  52. meson test -C build --print-errorlogs
  53. }
  54. package() {
  55. DESTDIR="$pkgdir" meson install -C build
  56. }