PKGBUILD 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104
  1. # Maintainer (Arch): Felix Yan <felixonmars@archlinux.org>
  2. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  3. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  4. # Contributor: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
  5. # Contributor: André Silva <emulatorman@hyperbola.info>
  6. pkgname=debootstrap
  7. pkgver=1.0.116
  8. pkgrel=1
  9. pkgrel+=.parabola2
  10. _pureospkgver=1.0.108
  11. _pureospkgrel=pureos2
  12. pkgdesc="Bootstrap a basic gNewSense and Trisquel system, without Debian support"
  13. arch=(any)
  14. license=(GPL)
  15. url="https://tracker.debian.org/pkg/debootstrap"
  16. depends=(wget binutils)
  17. source=("$pkgname-$pkgver.tar.gz::https://github.com/felixonmars/debootstrap/archive/$pkgver.tar.gz"
  18. "https://repo.puri.sm/pureos/pool/main/d/debootstrap/debootstrap_$_pureospkgver$_pureospkgrel.tar.gz"
  19. arch-detect.patch
  20. debootstrap.8
  21. gnewsense
  22. trisquel)
  23. optdepends=('gnupg: check release signatures'
  24. 'pureos-archive-keyring: check PureOS release signatures'
  25. 'trisquel-keyring: check Trisquel release signatures')
  26. sha512sums=('4b81bc56c6ac6e210aaceb06013882ba3cfe777d4173fd89d38a279fe57425302b86b2fb00ea2e19df2abfb7058909e1eb628f74f241612d865044b32e3481a4'
  27. '16888223cb3f4688ac468204bf4351080ac801456b990481602580f78666a034530b48d8bf6e989a53a393ab5edf6fdc80f5815be82fbfab3f9b845850da5d0b'
  28. '56e25f48027f99f7e720859a9e14fe769b1cbd6227c7a7e27e14c2fea88520109342d6e5b127dc34ce8cc40f46941a0c5157ad35cf8ef9b3e4323877a4b32d97'
  29. '0b3507756b8f29d19146df3201143ccbd71cfd1f7ef865d184079180612b90c046cabab59fe42d246bfe476ae8fd5c43e81ee2fc3ee06bbc1fc3e75d9f1382ca'
  30. '968ef005bf1f399b3400080b2ba65f1b32c067c49faadc1caa7ee524a85980f0a6625c7b06838e01bbd8b99a496492da77a38f0e17f0a81fc029ee611fe639b6'
  31. '06a352906de6f321f0bbd30667046eec3d9363774ba468d7dbe7c2d2cde92cca480ab4d595a84d594cd3f93ea0def1c67dc8f5bb1be6d669a29035ec289da668')
  32. prepare() {
  33. cd debootstrap-$pkgver
  34. sed -i 's/sbin/bin/g' Makefile
  35. # gNewSense/Trisquel defaults
  36. sed -i 's|export PATH|export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"|' debootstrap
  37. # Detect Architecture
  38. patch -p1 -i ../arch-detect.patch
  39. # Remove Debian files
  40. rm -v debootstrap.8
  41. # Add rebranded man
  42. install -m644 ../debootstrap.8 .
  43. # Remove (non-FSDG compliant) distributions's scripts
  44. for SCRIPT in scripts/* ; do
  45. case $SCRIPT in
  46. scripts/debian-common)
  47. ;;
  48. *)
  49. rm -v $SCRIPT
  50. ;;
  51. esac
  52. done
  53. # Add gNewSense script
  54. install -m644 $srcdir/gnewsense scripts
  55. # Add PureOS script
  56. install -m644 $srcdir/debootstrap/scripts/amber scripts/pureos
  57. # Add Trisquel script
  58. install -m644 $srcdir/trisquel scripts
  59. # Enter to scripts dir
  60. cd scripts
  61. # Create gNewSense symlinks
  62. ln -s gnewsense ucclia
  63. ln -s gnewsense parkes
  64. # Create PureOS symlinks
  65. ln -s pureos amber
  66. ln -s pureos green
  67. ln -s pureos landing
  68. ln -s pureos purple
  69. # Create Trisquel symlinks
  70. ln -s trisquel awen
  71. ln -s trisquel belenos
  72. ln -s trisquel brigantia
  73. ln -s trisquel dagda
  74. ln -s trisquel dwyn
  75. ln -s trisquel etiona
  76. ln -s trisquel flidas
  77. ln -s trisquel robur
  78. ln -s trisquel slaine
  79. ln -s trisquel taranis
  80. ln -s trisquel toutatis
  81. }
  82. package() {
  83. cd debootstrap-$pkgver
  84. make DESTDIR="$pkgdir" install
  85. install -Dm644 debootstrap.8 "$pkgdir"/usr/share/man/man8/debootstrap.8
  86. }