PKGBUILD 690 B

12345678910111213141516171819202122232425262728293031323334
  1. # Maintainer: Allan McRae <allan@archlinux.org>
  2. # Contributor: Andreas Radke <andyrtr@archlinux.org>
  3. pkgname=m4
  4. pkgver=1.4.18
  5. pkgrel=1
  6. pkgdesc="The GNU macro processor"
  7. arch=('x86_64' 'ppc64le')
  8. url="http://www.gnu.org/software/m4"
  9. license=('GPL3')
  10. groups=('base-devel')
  11. depends=('glibc' 'bash')
  12. source=(ftp://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.xz{,.sig})
  13. md5sums=('730bb15d96fffe47e148d1e09235af82'
  14. 'SKIP')
  15. validpgpkeys=('71C2CC22B1C4602927D2F3AAA7A16B4A2527436A') # Eric Blake
  16. build() {
  17. cd $pkgname-$pkgver
  18. ./configure --prefix=/usr
  19. make
  20. }
  21. check() {
  22. cd $pkgname-$pkgver
  23. make check
  24. }
  25. package() {
  26. cd $pkgname-$pkgver
  27. make prefix=${pkgdir}/usr install
  28. }