PKGBUILD 1.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # $Id$
  2. # Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
  3. # Contributor (Arch): Jan de Groot <jgc@archlinux.org>
  4. # Contributor (Arch): Tobias Kieslich <tobias@justdreams.de>
  5. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  6. # Contributor: André Silva <emulatorman@hyperbola.info>
  7. # Contributor: Márcio Silva <coadde@hyperbola.info>
  8. # parabola changes and rationale:
  9. # - removed support for possibly unsafe protocols
  10. pkgname=gthumb
  11. pkgver=3.8.3
  12. pkgrel=1
  13. pkgrel+=.nonprism1
  14. pkgdesc="Image browser and viewer for the GNOME Desktop, without support for unsafe and dangerous for privacy protocols"
  15. url="https://wiki.gnome.org/Apps/gthumb"
  16. arch=(x86_64 i686 armv7h)
  17. license=(GPL)
  18. depends=(dconf librsvg clutter-gtk gst-plugins-base-libs gsettings-desktop-schemas libwebp
  19. libsecret libsoup webkit2gtk json-glib gtk3-print-backends)
  20. makedepends=(libchamplain exiv2 brasero libraw liboauth docbook-xsl yelp-tools meson git)
  21. optdepends=('libraw: read RAW files'
  22. 'exiv2: metadata support'
  23. 'libchamplain: map viewer'
  24. 'brasero: burn discs'
  25. 'liboauth: web albums')
  26. _commit=ca8f528209ab78935c30e42fe53bdf1a24f3cb44 # tags/3.8.3^0
  27. source=("git+https://gitlab.gnome.org/GNOME/gthumb.git#commit=$_commit"
  28. nonprism.patch)
  29. sha256sums=('SKIP'
  30. 'ec0e5fdf9b7d48b90821e9ce9f7fdacc60fd843183c27479854d33f457805796')
  31. pkgver() {
  32. cd $pkgname
  33. git describe --tags | sed 's/-/+/g'
  34. }
  35. prepare() {
  36. cd $pkgname
  37. patch --verbose -Np1 -i ../nonprism.patch # Set meson_options to build without webservices
  38. rm ./data/icons/private/hicolor/16x16/actions/site-*.png # Get rid of the logos
  39. }
  40. build() {
  41. arch-meson $pkgname build -D libchamplain=true
  42. ninja -C build
  43. }
  44. check() {
  45. meson test -C build --print-errorlogs
  46. }
  47. package() {
  48. DESTDIR="$pkgdir" meson install -C build
  49. }