PKGBUILD 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Maintainer (aur): Stefan Majewsky <majewsky@gmx.net>
  2. # Maintainer: Luke Shumaker <lukeshu@parabola.nu>
  3. pkgname='holo'
  4. pkgver=2.2
  5. pkgrel=3
  6. pkgdesc='Minimalistic configuration management'
  7. arch=('i686' 'x86_64' 'armv7h')
  8. url='http://holocm.org'
  9. license=('GPL3')
  10. depends=()
  11. optdepends=(
  12. 'git: to display diffs of entities'
  13. 'openssh: for the holo-ssh-keys plugin'
  14. 'shadow: for the holo-users-groups plugin'
  15. )
  16. makedepends=('go' 'perl')
  17. checkdepends=('git' 'openssh')
  18. provides=(
  19. # required for holo-build packages that have a holo-$PLUGIN dependency when there are files below /usr/share/holo/$PLUGIN/
  20. "holo-files=${pkgver}"
  21. "holo-run-scripts=${pkgver}"
  22. "holo-ssh-keys=${pkgver}"
  23. "holo-users-groups=${pkgver}"
  24. )
  25. conflicts=("${provides[@]%=*}")
  26. replaces=("${provides[@]%=*}")
  27. backup=(
  28. 'etc/holorc'
  29. 'etc/holorc.d/10-files'
  30. 'etc/holorc.d/20-users-groups'
  31. 'etc/holorc.d/25-ssh-keys'
  32. 'etc/holorc.d/95-holo-run-scripts'
  33. )
  34. # patch info
  35. pkgver+=.lukeshu1
  36. pkgrel+=.1
  37. pkgdesc+=" (with patches from lukeshu)"
  38. _gitver='commit=ec2b9a5a3d2d3384a84ed45dbc38eb689003e835'
  39. mksource=("$pkgname-$pkgver::git+https://github.com/lukeshu/holo#$_gitver")
  40. mkmd5sums=('SKIP')
  41. replaces+=('holo-lukeshu')
  42. source=("https://repo.parabola.nu/other/~lukeshu/holo/$pkgname-$pkgver.tar.gz")
  43. sha256sums=('ad64d5af1b08a6ec0053fe9a729052152d3f77c8488f791cc99cee5c12faf72d')
  44. options=('!strip') # binaries are already stripped inside the Makefile
  45. build() {
  46. cd "${srcdir}/${pkgname}-${pkgver}"
  47. make
  48. }
  49. check() {
  50. cd "${srcdir}/${pkgname}-${pkgver}"
  51. make check
  52. }
  53. package() {
  54. cd "${srcdir}/${pkgname}-${pkgver}"
  55. make install DESTDIR="${pkgdir}"
  56. }