PKGBUILD 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Maintainer (arch): Sven-Hendrik Haase <sh@lutzhaase.com>
  2. # Contributor: Johan Rehnberg <cleanrock@gmail.com>
  3. # This package is in Parabola only for architectures that don't have xonotic in
  4. # their feed. Here is the status of xonotic in the various upstream
  5. # GNU/Linux distributions Parabola is based on:
  6. # +--------------+----------------+---------------+
  7. # | Architecture | Upstream | Upstream repo |
  8. # +--------------+----------------+---------------+
  9. # | armv7h | Arch Linux ARM | None |
  10. # | i686 | Arch Linux 32 | community |
  11. # | x86_64 | Arch Linux | community |
  12. # +--------------+----------------+---------------+
  13. pkgname=naev
  14. pkgver=0.7.0
  15. pkgrel=2
  16. pkgdesc='2D action/rpg space game'
  17. arch=('armv7h')
  18. url="http://sourceforge.net/projects/naev/"
  19. license=('GPL3')
  20. depends=('glu' 'openal' 'libvorbis' 'sdl2' 'sdl2_image' 'sdl2_mixer' 'libgl' 'libxml2' 'freetype2' 'libpng' 'libzip' 'luajit')
  21. makedepends=('freeglut' 'zip')
  22. source=("https://github.com/naev/naev/archive/naev-${pkgver}.tar.gz")
  23. md5sums=('c07e24c2e87d08fdb73e666fb4e59981')
  24. build() {
  25. cd "$srcdir/$pkgname-$pkgname-$pkgver"
  26. ./autogen.sh
  27. ./configure --prefix=/usr --disable-debug --disable-shave --with-ndata-path=/usr/share/naev/ndata
  28. make
  29. }
  30. package() {
  31. cd "$srcdir/$pkgname-$pkgname-$pkgver"
  32. make DESTDIR="$pkgdir/" install
  33. }