PKGBUILD 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Maintainer (aur): Maxim Andersson <thesilentboatman@gmail.com>
  2. # Based on the mailpile-git PKGBUILD
  3. # Contributor: cornholio <vigo.the.unholy.carpathian@gmail.com>
  4. # parabola changes and rationale:
  5. # no changes.
  6. pkgname=mailpile
  7. pkgver=1.0.0rc1
  8. pkgrel=1
  9. pkgdesc="A modern, fast web-mail client with user-friendly encryption and privacy features."
  10. arch=('any')
  11. url="http://www.mailpile.is"
  12. license=('AGPL3')
  13. depends=('gnupg' 'python2-appdirs' 'python2-cryptography' 'python2-jinja>=2.6' 'python2-lxml>=2.3.2' 'python2-markupsafe' 'python2-pbr' 'python2-pgpdump' 'python2-pillow' 'python2-pydns' 'python2-setuptools' 'spambayes>=1.1a6')
  14. install=${pkgname}.install
  15. source=("${pkgname}-${pkgver}.zip::https://github.com/mailpile/Mailpile/archive/88ae8e5831dddc628c827c44224166dbdbed91f1.zip"
  16. #"https://github.com/mailpile/${pkgname}/archive/${pkgver}.tar.gz"
  17. "${pkgname}.service")
  18. sha256sums=('7eeb45c261341dce5b3d56fecd1799825fc914b5a4392a3cbcc0c4b53c00fae5'
  19. '07adbd61cda225bf11818d39776240ee1077a3f2ddc9e5ef0f11825dd4ca504d')
  20. prepare() {
  21. cd "${srcdir}/Mailpile-"*
  22. # Set absolute path
  23. sed -i '5,9c mailpile_root = "/usr/share/mailpile"' mp
  24. }
  25. build() {
  26. cd "${srcdir}/Mailpile-"*
  27. # Compile bytecode
  28. python2 -m compileall -f mailpile
  29. }
  30. package() {
  31. cd "${srcdir}/Mailpile-"*
  32. install -d "${pkgdir}/usr/share/${pkgname}"
  33. cp -r shared-data/* "${pkgdir}/usr/share/${pkgname}/"
  34. cp -r mailpile "${pkgdir}/usr/share/${pkgname}/"
  35. install -D mp -t "${pkgdir}/usr/bin"
  36. install -Dm644 "../${pkgname}.service" -t "${pkgdir}/usr/lib/systemd/system"
  37. }
  38. # vim:set ts=2 sw=2 et: