PKGBUILD 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Maintainer (arch): speps <speps at aur dot archlinux dot org>
  2. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  3. pkgname=gnoduino
  4. pkgver=0.5.1
  5. pkgrel=2
  6. pkgdesc="An implementation of well-known Arduino IDE for GNOME"
  7. arch=(any)
  8. url="http://gnome.eu.org/index.php/Gnoduino"
  9. license=('GPL')
  10. depends=('avr-libc' 'avrdude' 'avr-binutils' 'avr-gcc' 'pyxdg'
  11. 'pygtksourceview2' 'python2-pyserial'
  12. 'python2-gconf' 'desktop-file-utils')
  13. makedepends=('python2-distribute')
  14. install="$pkgname.install"
  15. source=("http://gnome.eu.org/$pkgname-$pkgver.tar.gz")
  16. md5sums=('e458acd24860e28acec7fa71bb9cfe2f')
  17. prepare() {
  18. cd $pkgname-$pkgver
  19. # do not install gconf schema
  20. sed -i "/installSchema.*)$/d" setup.py
  21. # python2 shebang
  22. sed -i "s|bin/python$|&2|" `find . -name "*.py"`
  23. }
  24. build() {
  25. cd $pkgname-$pkgver
  26. python2 setup.py build
  27. }
  28. package() {
  29. cd $pkgname-$pkgver
  30. python2 setup.py install --root="$pkgdir/"
  31. # gconf schema
  32. install -Dm644 data/$pkgname.schemas \
  33. "$pkgdir/usr/share/gconf/schemas/$pkgname.schemas"
  34. }
  35. # vim:set ts=2 sw=2 et: