PKGBUILD 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Maintainer (aur): Colin Shea <colin@evaryont.me>
  2. # Maintainer: Aurélien Desbrières <aurelien@hackers.camp>
  3. # parabola changes and rationale:
  4. # no changes.
  5. pkgname=fwsnort
  6. pkgver=1.6.3
  7. pkgrel=3.1
  8. pkgdesc="application layer IDS/IPS by translating snort rules into iptables"
  9. arch=('any')
  10. url="http://www.cipherdyne.org/fwsnort/"
  11. license=('GPL')
  12. # net-tools: sorry, but fwsnort needs ifconfig. Doesn't support iproute yet
  13. depends=('perl' 'perl-netaddr-ip' 'perl-iptables-parse' 'iptables' 'net-tools')
  14. makedepends=('wget')
  15. source=(http://www.cipherdyne.org/$pkgname/download/$pkgname-$pkgver.tar.bz2
  16. 'install_pl.patch')
  17. md5sums=('3e7501e4587a3e33615b604935c75e4e'
  18. 'd7925e3f869ec8decb0e8336801350d6')
  19. options=(emptydirs)
  20. build() {
  21. cd "$srcdir/$pkgname-$pkgver"
  22. # fix up the installer for our purposes:
  23. # - removes the root check
  24. # - includes sbin as another place to check for binares
  25. # - fixes various paths for utilities & the man page
  26. patch -p1 -i $srcdir/install_pl.patch
  27. # -S skips installing the perl modules, which we did with packages
  28. # and --install-test-dir sets the INSTALL_ROOT to src/../test/fwsnort-test. An
  29. # easy way to collect all the files into 1
  30. ./install.pl -S --install-test-dir
  31. }
  32. package() {
  33. cp -r $srcdir/fwsnort-$pkgver/test/fwsnort-install/* -t $pkgdir
  34. # delete references to $pkgdir from fwsnort; they were made by the installer
  35. # as part of installing to the test dir
  36. cp -f $srcdir/fwsnort-$pkgver/fwsnort.conf $pkgdir/etc/fwsnort/fwsnort.conf
  37. # avoid a 'warning: directory permissions differ on etc/' line from pacman
  38. chmod 755 $pkgdir/etc
  39. }
  40. # vim:set ts=2 sw=2 et: