PKGBUILD 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # $Id: PKGBUILD 189356 2016-09-15 20:21:37Z svenstaro $
  2. # Contributor: Aaron Griffin <aaron@archlinux.org>
  3. # Maintainer (arch): Sven-Hendrik Haase <sh@lutzhaase.com>
  4. # Contributor: André Silva <emulatorman@hyperbola.info>
  5. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  6. _pkgname=vim-colorsamplerpack-libre
  7. pkgname=vim-colorsamplerpack
  8. pkgver=2012.10.28
  9. pkgrel=5
  10. pkgrel+=.par1
  11. _scriptid=18915
  12. pkgdesc="Different colorschemes for vim, without nonfree colorschemes"
  13. arch=('any')
  14. url="http://www.vim.org/scripts/script.php?script_id=625"
  15. license=('GPL2' 'GPL3' 'custom')
  16. replaces=($_pkgname)
  17. conflicts=($_pkgname)
  18. depends=('vim')
  19. makedepends=('unzip')
  20. groups=('vim-plugins')
  21. mksource=(ColorSamplerPack.zip::"http://www.vim.org/scripts/download_script.php?src_id=$_scriptid")
  22. source=("https://repo.parabola.nu/other/${_pkgname}/ColorSamplerPack-libre.tar.xz"
  23. 'LICENSE')
  24. mksha256sums=('2d0b07a36fa52728f45850933a35ab6172913262fb3aaa2cb32e597cf75859f3')
  25. sha256sums=('b1f2bbe6ab7ee4fcce66aca812726919f96d013caf8a6c68b242c59b48269d17'
  26. '6d9e25d62ca66835eb24209c8e7ef973932165f65e96f615639027418ab6742d')
  27. mksource() {
  28. # Remove nonfree colorschemes
  29. cd ${srcdir}
  30. mv colors colors-tmp
  31. install -d colors
  32. install -m644 colors-tmp/{calmar256-light,cleanphp,dante,ekvoli,lettuce,marklar,martin_krischik,motus,railscasts,relaxedgreen,synic,tabula,vibrantink,vividchalk,xoria256,zenburn}.vim colors
  33. rm -rv colors-tmp
  34. }
  35. package() {
  36. cd ${srcdir}
  37. installpath="${pkgdir}/usr/share/vim/vimfiles"
  38. install -Dm 644 colors/* -t "${installpath}/colors"
  39. install -Dm 644 plugin/color_sample_pack.vim "${installpath}/plugin/themes.vim"
  40. install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
  41. }