PKGBUILD 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Maintainer (arch): Sven-Hendrik Haase <sh@lutzhaase.com>
  2. # Contributor: Sandy Carter <bwrsandman@gmail.com>
  3. # Contributor: André Silva <emulatorman@hyperbola.info>
  4. pkgname=openmw
  5. pkgver=0.45.0
  6. pkgrel=1
  7. pkgrel+=.parabola1
  8. pkgdesc="Open-source engine reimplementation for the role-playing game Morrowind"
  9. pkgdesc+=", without without downloader/installer wizard"
  10. arch=('x86_64')
  11. arch+=('i686')
  12. url="http://www.openmw.org"
  13. license=('GPL3' 'MIT' 'custom')
  14. depends=('openal' 'openscenegraph34' 'mygui' 'bullet' 'qt5-base' 'ffmpeg' 'sdl2' 'unshield' 'libxt')
  15. makedepends=('cmake' 'boost' 'doxygen' 'ninja')
  16. source=("https://github.com/OpenMW/openmw/archive/openmw-${pkgver}.tar.gz"
  17. disable_wizard.patch)
  18. sha256sums=('b63cf971f406ef5f28019f65e9e2bd9641a227459ede45d147562917f67e1c64'
  19. 'bb60055d501186cada01e151551a3db5c1d67c3ae6584a2799eef0e273ba14eb')
  20. prepare() {
  21. mkdir build
  22. # this patch could be upstreamed
  23. # when the user is missing game data (the default case),
  24. # the program asks to run the dowloader wizard
  25. # even though it could have detected that the wizard was not compiled (BUILD_WIZARD=OFF)
  26. # then if the user presses the wizard button,
  27. # it fails with a GUI warning about the non-existing wizard
  28. cd "$srcdir"/$pkgname-$pkgname-$pkgver
  29. patch -p1 < "$srcdir"/disable_wizard.patch
  30. }
  31. build() {
  32. cd build
  33. cmake "../$pkgname-$pkgname-$pkgver" \
  34. -DCMAKE_INSTALL_PREFIX=/usr \
  35. -DCMAKE_BUILD_TYPE=Release \
  36. -DDESIRED_QT_VERSION=5 \
  37. -DBUILD_ESSIMPORTER=OFF \
  38. -DBUILD_WIZARD=OFF \
  39. -GNinja
  40. ninja
  41. }
  42. package() {
  43. DESTDIR="$pkgdir" ninja -C build install
  44. }