PKGBUILD 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. # Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
  2. # Contributor: Andrea Scarpino <andrea@archlinux.org>
  3. # Contributor: Giovanni Scafora <giovanni@archlinux.org>
  4. # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
  5. # Contributor: bill-auger <bill-auger@programmer.net>
  6. # Contributor: SolveFinder <kwopleq@proton.me>
  7. # parabola changes and rationale:
  8. # - replace 'qt5-webengine' dependency with 'qt5-webkit'
  9. # - pin to strongly-coupled dependency versions
  10. pkgname=kdevelop
  11. pkgver=24.02.0
  12. _clangver=17.0.6
  13. [[ "${CARCH}" == i686 ]] && _clangver=15.0.7
  14. pkgrel=2
  15. pkgrel+=.parabola1
  16. pkgdesc='C++ IDE using KDE technologies'
  17. arch=(x86_64)
  18. arch+=(armv7h i686)
  19. url='http://www.kdevelop.org/'
  20. # license=(GPL-2.0-or-later) # TODO:
  21. license=(GPL)
  22. depends=(clang=$_clangver
  23. gcc-libs
  24. glibc
  25. grantlee
  26. karchive5
  27. kbookmarks5
  28. kcmutils5
  29. kcodecs5
  30. kcompletion5
  31. kconfig5
  32. kconfigwidgets5
  33. kcoreaddons5
  34. kcrash5
  35. kdeclarative5
  36. kguiaddons5
  37. ki18n5
  38. kiconthemes5
  39. kio5
  40. kitemmodels5
  41. kitemviews5
  42. kjobwidgets5
  43. knewstuff5
  44. knotifications5
  45. knotifyconfig5
  46. kparts5
  47. kservice5
  48. ktexteditor5
  49. ktextwidgets5
  50. kwidgetsaddons5
  51. kwindowsystem5
  52. kxmlgui5
  53. libkomparediff2
  54. # libksysguard
  55. qt5-base
  56. qt5-declarative
  57. qt5-webengine
  58. sh
  59. sonnet5
  60. syntax-highlighting5
  61. threadweaver5)
  62. depends=( ${depends[*]/qt5-webengine/qt5-webkit} )
  63. makedepends=(astyle
  64. boost
  65. extra-cmake-modules
  66. kdevelop-pg-qt
  67. kdoctools5
  68. # krunner5
  69. llvm
  70. okteta
  71. plasma-framework5
  72. purpose5
  73. qt5-tools
  74. subversion)
  75. optdepends=('apr: SVN support'
  76. 'apr-util: SVN support'
  77. 'astyle: astyle plugin'
  78. 'clazy: clazy analyzer plugin'
  79. 'cmake: cmake integration'
  80. 'cppcheck: code analyzer'
  81. 'gdb: GNU debugger support'
  82. 'git: Git support'
  83. 'heaptrack: memory profiler'
  84. 'kate: for additional plugins'
  85. 'kio5-extras: man pages plugin'
  86. 'konsolepart5: embedded terminal'
  87. 'lldb-mi: LLDB debugger support'
  88. 'meson: meson integration'
  89. 'okteta: GNU debugger support'
  90. 'plasma-framework5: for the plasma addons'
  91. 'purpose5: patch review plugin'
  92. 'python: debugger support'
  93. 'subversion: SVN support'
  94. 'qt5-doc: Qt documentation integration'
  95. 'qt5-tools: qthelp plugin'
  96. 'subversion: SVN support')
  97. groups=(kde-applications
  98. kdevelop)
  99. source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
  100. sha256sums=('202acdfb53b1bdeeb9915eab1a0056d190040d8809038950bf2ec8d44fa81e19'
  101. 'SKIP')
  102. validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
  103. F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
  104. D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
  105. ## dependency tweaks ##
  106. case "${CARCH}" in
  107. i686) # arch32 has not renamed these k*5 packages yet
  108. depends=( ${depends[*]%5} )
  109. makedepends=( ${makedepends[*]%5} )
  110. optdepends=( "${optdepends[@]/kio5-extras:/kio-extras:}" )
  111. optdepends=( "${optdepends[@]/konsolepart5:/konsolepart:}" )
  112. optdepends=( "${optdepends[@]/plasma-framework5:/plasma-framework:}" )
  113. optdepends=( "${optdepends[@]/purpose5:/purpose:}" )
  114. ;;
  115. esac
  116. build() {
  117. cmake -B build -S $pkgname-$pkgver \
  118. -DBUILD_TESTING=OFF
  119. cmake --build build
  120. }
  121. package() {
  122. # pin to strongly-coupled dependency versions
  123. depends+=( libicu{data,i18n,uc}.so ) # dependency is via qt5-webkit->icu
  124. DESTDIR="$pkgdir" cmake --install build
  125. }