PKGBUILD 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Maintainer (arch): Felix Yan <felixonmars@archlinux.org>
  2. # Contributor: csslayer <wengxt AT gmail com>
  3. # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
  4. # parabola changes and rationale:
  5. # - replace webengine dependency with webkit
  6. # use '-DENABLE_BROWSER=OFF' instead, if we ever need to drop 'qt5-webkit'
  7. # FTBS armv7h: because qt5-webit FTBS
  8. # FTBS i686: Could not find a configuration file for package "Fcitx5Core" that is compatible with requested version "5.1.6".
  9. pkgname=fcitx5-chinese-addons
  10. pkgver=5.1.3
  11. pkgrel=1
  12. pkgrel=1.parabola1
  13. pkgdesc="Addons related to Chinese, including IME previous bundled inside fcitx4"
  14. arch=('x86_64')
  15. arch+=('armv7h' 'i686')
  16. url="https://github.com/fcitx/fcitx5-chinese-addons"
  17. license=('GPL')
  18. conflicts=('fcitx')
  19. depends=('curl' 'fcitx5-qt' 'libime' 'opencc' 'qt5-webengine')
  20. depends=( ${depends[*]/qt5-webengine/qt5-webkit} )
  21. makedepends=('boost' 'extra-cmake-modules' 'fcitx5-lua' 'fmt' 'ninja')
  22. optdepends=('fcitx5-lua: Lua and imeapi support from pinyin')
  23. source=("https://download.fcitx-im.org/fcitx5/$pkgname/$pkgname-${pkgver}_dict.tar.xz"{,.sig})
  24. sha512sums=('4ea52ec45af70b552d8d4af3ed077662d6d839d3984bc41858b4710fe5b1dc169c63e223770f5400718c1c18aa745e77305f242409fa1cc523cee8475eb2e9ff'
  25. 'SKIP')
  26. validpgpkeys=('2CC8A0609AD2A479C65B6D5C8E8B898CBF2412F9') # Weng Xuetian <wengxt@gmail.com>
  27. build() {
  28. cd $pkgname-$pkgver
  29. cmake -GNinja -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -DUSE_WEBKIT=ON .
  30. ninja
  31. }
  32. check() {
  33. cd $pkgname-$pkgver
  34. ninja test
  35. }
  36. package() {
  37. cd $pkgname-$pkgver
  38. DESTDIR="$pkgdir" ninja install
  39. }