PKGBUILD 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081
  1. # vim:set ft=sh:
  2. # Maintainer (arch): BlackIkeEagle <ike DOT devolder AT gmail DOT com>
  3. # Contributor: (sirocco AT ngs.ru)
  4. # Contributor: André Silva <emulatorman@hyperbola.info>
  5. # parabola changes and rationale:
  6. # - removed libunrar support
  7. pkgbase=doublecmd
  8. pkgname=('doublecmd-gtk2' 'doublecmd-qt5')
  9. pkgver=0.9.8
  10. pkgrel=1
  11. pkgrel+=.parabola1
  12. url="http://doublecmd.sourceforge.net/"
  13. arch=('x86_64')
  14. arch+=('i686' 'armv7h')
  15. license=('GPL')
  16. provides=("$pkgbase")
  17. makedepends=('lazarus' 'qt5pas' 'gtk2')
  18. optdepends=(
  19. 'lua: scripting'
  20. 'unzip: support extracting zip archives'
  21. 'zip: suport packing zip archives'
  22. 'p7zip: support for 7zip archives'
  23. )
  24. source=(
  25. "https://downloads.sourceforge.net/project/$pkgbase/Double%20Commander%20Source/$pkgbase-$pkgver-src.tar.gz"
  26. "libre.patch"
  27. )
  28. sha512sums=('e44e4e697cbea0cec08fbac7336cb980ae2a1f72e807435b6e25aa81baf5fc0b94d378161cb36199e0fe42242101c7ce30301c07d1195f5b6252e63cef443682'
  29. 'f8a38cbae2c6ee0e0a40802daa5b779c6c07ae2d35b5adc119118318740585704b19bb6fb4d7edfb6ea54cad08f6381ef07ddae08f55bfbd38a1909e34fc3bea')
  30. prepare() {
  31. cp -a /usr/lib/lazarus ./
  32. cd "$pkgbase-$pkgver"
  33. sed -e 's/LIB_SUFFIX=.*/LIB_SUFFIX=/g' -i install/linux/install.sh
  34. sed -e "s@=\$(which lazbuild)@=\"\$(which lazbuild) --lazarusdir=$srcdir/lazarus\"@" -i build.sh
  35. msg2 'remove nonfree libunrar, unace, unarj support and references'
  36. rm -rv plugins/wcx/unrar
  37. rm -rv install/linux/deb/libunrar
  38. rm -v install/linux/rpm/libunrar.spec
  39. rm -v install/darwin/make-unrar.sh
  40. patch -Np1 -i "$srcdir"/libre.patch
  41. cd "$srcdir"
  42. cp -a "$pkgbase-$pkgver" "$pkgbase-gtk"
  43. cp -a "$pkgbase-$pkgver" "$pkgbase-qt5"
  44. }
  45. build() {
  46. msg2 'build gtk'
  47. cd "$srcdir/$pkgbase-gtk"
  48. ./build.sh beta gtk2
  49. msg2 'build qt5'
  50. cd "$srcdir/$pkgbase-qt5"
  51. ./build.sh beta qt5
  52. }
  53. package_doublecmd-gtk2() {
  54. pkgdesc="twin-panel (commander-style) file manager (GTK2)"
  55. pkgdesc+=", without nonfree decompression engine for RAR archives and support for nonfree unace and unarj"
  56. depends=('gtk2' 'desktop-file-utils' 'hicolor-icon-theme' 'shared-mime-info')
  57. conflicts=('doublecmd-qt5')
  58. cd "$srcdir/$pkgbase-gtk"
  59. ./install/linux/install.sh --install-prefix="$pkgdir"
  60. }
  61. package_doublecmd-qt5() {
  62. pkgdesc="twin-panel (commander-style) file manager (Qt5)"
  63. pkgdesc+=", without nonfree decompression engine for RAR archives and support for nonfree unace and unarj"
  64. depends=('qt5pas' 'desktop-file-utils' 'hicolor-icon-theme' 'shared-mime-info')
  65. conflicts=('doublecmd-gtk2')
  66. replaces=('doublecmd-qt' 'doublecmd-qt4')
  67. cd "$srcdir/$pkgbase-qt5"
  68. ./install/linux/install.sh --install-prefix="$pkgdir"
  69. }