PKGBUILD 3.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. # Maintainer (arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
  2. # Contributor: Gaetan Bisson <bisson@archlinux.org>
  3. # Contributor: Giovanni Scafora <giovanni@archlinux.org>
  4. # Contributor: James Rayner <james@archlinux.org>
  5. # Contributor: Partha Chowdhury <kira.laucas@gmail.com>
  6. # Maintainer: Freemor <freemor@freemor.ca>
  7. # Contributor: bill-auger <bill-auger@programmer.net>
  8. # parabola changes and rationale:
  9. # - arch package depends on blacklisted 'libxnvctrl'
  10. # - arch package is built from VCS
  11. # - arch package does not install BSD license
  12. # - arch package does not declare all upstream licenses
  13. pkgname=conky
  14. pkgver=1.12.2
  15. pkgrel=2
  16. pkgrel+=.parabola1
  17. pkgdesc='Lightweight system monitor for X'
  18. url='https://github.com/brndnmtthws/conky'
  19. license=('Boost' 'BSD' 'GPL3' 'ISC' 'LGPL')
  20. arch=('x86_64')
  21. arch+=('armv7h' 'i686')
  22. makedepends=('cmake' 'docbook2x' 'docbook-xsl' 'man-db' 'git' 'catch2')
  23. depends=(
  24. 'glibc' 'glib2' 'lua' 'wireless_tools' 'libxdamage' 'libxinerama' 'libxft' 'imlib2'
  25. 'libxml2' 'libpulse' 'libxnvctrl' 'systemd-libs' 'ncurses' 'curl'
  26. libncursesw.so libXNVCtrl.so libsystemd.so libpulse.so libcurl.so)
  27. depends=( ${depends[*]/libxnvctrl/} )
  28. depends=( ${depends[*]/libXNVCtrl.so/} )
  29. source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brndnmtthws/conky/archive/v${pkgver}.tar.gz")
  30. sha512sums=('55280953da437efe36320e4c12f74d95b8406bd7d8b7d93c6582f9b346c1c80a94b71d1c27860f6274de9171865fca91e330dfc39feb80bb2f453a538bc5ce1a')
  31. b2sums=('b8d1b40dc4b547679b5ab4bf0328aabaac868025433729f48baf572c536da4a527a073a6d47f36c179851aecef58535dccb956e3a695700f06bf8e6ab170ae1f')
  32. validpgpkeys=(
  33. 'EB2E847572A71BE20F59AFBEB49ABB7270D9D4FD' # Brenden Matthews
  34. )
  35. prepare() {
  36. cd ${pkgname}-${pkgver}
  37. # NOTE: The Boost license applies only to 'catch2',
  38. # which is deleted (temporarily) as a bug fix.
  39. # If this becomes a permanent treatment,
  40. # 'Boost' can be deleted from the license' array.
  41. # Unbundle catch2 to fix build with glibc 2.35
  42. rm -r tests/catch2
  43. ln -s /usr/include/catch2 tests
  44. # prepare missing ISC license
  45. head -n 17 src/prss.h > LICENSE.ISC
  46. }
  47. build() {
  48. cd ${pkgname}-${pkgver}
  49. cmake \
  50. -B build \
  51. -D CMAKE_BUILD_TYPE=Release \
  52. -D CMAKE_CXX_FLAGS="$CXXFLAGS -ffat-lto-objects" \
  53. -D MAINTAINER_MODE=ON \
  54. -D BUILD_DOCS=ON \
  55. -D BUILD_WLAN=ON \
  56. -D BUILD_XDBE=ON \
  57. -D BUILD_XSHAPE=ON \
  58. -D BUILD_IMLIB2=ON \
  59. -D BUILD_CURL=ON \
  60. -D BUILD_RSS=ON \
  61. -D BUILD_NVIDIA=OFF \
  62. -D BUILD_WEATHER_METAR=ON \
  63. -D BUILD_PULSEAUDIO=ON \
  64. -D BUILD_JOURNAL=ON \
  65. -D CMAKE_INSTALL_PREFIX=/usr \
  66. -Wno-dev \
  67. -S .
  68. make -C build
  69. }
  70. package() {
  71. cd ${pkgname}-${pkgver}
  72. make -C build DESTDIR="${pkgdir}" install
  73. install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
  74. install -Dm 644 LICENSE.BSD -t "${pkgdir}/usr/share/licenses/${pkgname}"
  75. install -Dm 644 LICENSE.ISC -t "${pkgdir}/usr/share/licenses/${pkgname}"
  76. install -Dm 644 extras/vim/syntax/conkyrc.vim -t "${pkgdir}"/usr/share/vim/vimfiles/syntax
  77. install -Dm 644 extras/vim/ftdetect/conkyrc.vim -t "${pkgdir}"/usr/share/vim/vimfiles/ftdetect
  78. }