PKGBUILD 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391
  1. # Maintainer: David P. <megver83@parabola.nu>
  2. # Contributor: André Silva <emulatorman@hyperbola.info>
  3. # Contributor: Márcio Silva <coadde@hyperbola.info>
  4. # Contributor: fauno <fauno@parabola.nu>
  5. # Contributor: Sorin-Mihai Vârgolici <smv@yobicore.org>
  6. # Contributor: Michał Masłowski <mtjm@mtjm.eu>
  7. # Contributor: Luke R. <g4jc@openmailbox.org>
  8. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  9. # Based on linux package
  10. _replacesarchkernel=('linux%') # '%' gets replaced with kernel suffix
  11. _replacesoldkernels=() # '%' gets replaced with kernel suffix
  12. _replacesoldmodules=() # '%' gets replaced with kernel suffix
  13. pkgbase=linux-libre
  14. pkgver=5.13.8
  15. pkgrel=1
  16. pkgdesc='Linux-libre'
  17. rcnver=5.11.11
  18. rcnrel=armv7-x14
  19. url='https://linux-libre.fsfla.org/'
  20. arch=(i686 x86_64 armv7h)
  21. license=(GPL2)
  22. makedepends=(
  23. bc kmod libelf pahole cpio perl tar xz
  24. xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
  25. )
  26. makedepends_armv7h=(uboot-tools vboot-utils dtc) # required by linux-libre-chromebook
  27. options=('!strip')
  28. _srcname=linux-5.13
  29. source=(
  30. "https://linux-libre.fsfla.org/pub/linux-libre/releases/${_srcname##*-}-gnu/linux-libre-${_srcname##*-}-gnu.tar.xz"{,.sign}
  31. "https://linux-libre.fsfla.org/pub/linux-libre/releases/$pkgver-gnu/patch-${_srcname##*-}-gnu-$pkgver-gnu.xz"{,.sign}
  32. "https://repo.parabola.nu/other/linux-libre/logos/logo_linux_"{clut224.ppm,vga16.ppm,mono.pbm}{,.sig}
  33. config.i686 config.x86_64 config.armv7h # the main kernel config files
  34. linux-armv7h.preset # armv7h preset file for mkinitcpio ramdisk
  35. "kernel"{.its,.keyblock,_data_key.vbprivk} # files for signing Chromebooks kernels
  36. # maintain the TTY over USB disconnects
  37. # http://www.coreboot.org/EHCI_Gadget_Debug
  38. 0001-usb-serial-gadget-no-TTY-hangup-on-USB-disconnect-WI.patch
  39. # fix Atmel maXTouch touchscreen support
  40. # https://labs.parabola.nu/issues/877
  41. # http://www.fsfla.org/pipermail/linux-libre/2015-November/003202.html
  42. 0002-fix-Atmel-maXTouch-touchscreen-support.patch
  43. # Arch Linux patches
  44. 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
  45. 0002-Bluetooth-btusb-check-conditions-before-enabling-USB.patch
  46. )
  47. source_i686=(
  48. # avoid using zstd compression in ultra mode (exhausts virtual memory)
  49. no-ultra-zstd.patch
  50. )
  51. source_armv7h=(
  52. # RCN patch (CM3 firmware deblobbed and bloatware removed)
  53. "https://repo.parabola.nu/other/rcn-libre/patches/$rcnver/rcn-libre-$rcnver-$rcnrel.patch"{,.sig}
  54. # Arch Linux ARM patches
  55. 0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch
  56. 0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch
  57. 0003-SMILE-Plug-device-tree-file.patch
  58. 0004-fix-mvsdio-eMMC-timing.patch
  59. 0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
  60. 0006-set-default-cubietruck-led-triggers.patch
  61. 0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
  62. 0008-ARM-dove-enable-ethernet-on-D3Plug.patch
  63. 0009-USB-Armory-MkII-support.patch
  64. # ChromiumOS patches
  65. 0001-CHROMIUM-block-partitions-efi-Add-support-for-IGNORE.patch
  66. )
  67. validpgpkeys=(
  68. '474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
  69. '6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
  70. )
  71. sha512sums=('a24f2db9316297127447b3d7fd7a1e9e7b9a8bdb5e59e6e341568cbf877c4b65d2ccdb27ec1c23b07af6c365b2930b040bcef0d989202b503bc55b107c04d121'
  72. 'SKIP'
  73. '53a9a1abfb8ae6e73337986ed780034d5ecf4d89bf1bbf7d4c2b5b04b527b00296c7c427045c8ab454a175db1ab272c76ef115edd4b88f4f530cbd884e604bb5'
  74. 'SKIP'
  75. '13cb5bc42542e7b8bb104d5f68253f6609e463b6799800418af33eb0272cc269aaa36163c3e6f0aacbdaaa1d05e2827a4a7c4a08a029238439ed08b89c564bb3'
  76. 'SKIP'
  77. '7a3716bfe3b9f546da309c7492f3e08f8f506813afeb1c737a474c83313d5c313cf4582b65215c2cfce3b74d9d1021c96e8badafe8f6e5b01fe28d2b5c61ae78'
  78. 'SKIP'
  79. '267295aa0cea65684968420c68b32f1a66a22d018b9d2b2c1ef14267bcf4cb68aaf7099d073cbfefe6c25c8608bdcbbd45f7ac8893fdcecbf1e621abdfe9ecc1'
  80. 'SKIP'
  81. '929fd5c34b07a63b5e50296523a6b3686ac9014a74ed5e41b0b1f0b169306ee2dace9e9259b4222c84fb1edb9a96e09bcd3d7f0e5611bef93f5c8754a67a3367'
  82. 'e78d10fe5d709e714dfc2e56a487de7d03e0fcaca17d48cd279659ab930f44ef903683d3f6f10b1330f59f15e80c7571f6bd3d47d75fdaed7d93999346b8af57'
  83. '51e8b4da770067e8257d292622d865cb16ac57fdfd8967bdfb74efec197dae9eab958e5637a728640ae60885bdde41c06c8076227a4f83db0b752215f91f3a87'
  84. '53103bf55b957b657039510527df0df01279dec59cda115a4d6454e4135025d4546167fa30bdc99107f232561c1e096d8328609ab5a876cf7017176f92ad3e0b'
  85. '167bc73c6c1c63931806238905dc44c7d87c5a5c0f6293159f2133dfe717fb44081018d810675716d1605ec7dff5e8333b87b19e09e2de21d0448e447437873b'
  86. 'bb6718984a7357c9b00c37e4788480e5b8b75018c172ecc1441bc3fc5d2d42444eb5d8c7f9d2e3a7d6fed6d03acb565e3c0559486e494c40a7fe6bd0570c9ede'
  87. '143dea30c6da00e504c99984a98a0eb2411f558fcdd9dfa7f607d6c14e9e7dffff9cb00121d9317044b07e3e210808286598c785ee854084b993ec9cb14d8232'
  88. '02af4dd2a007e41db0c63822c8ab3b80b5d25646af1906dc85d0ad9bb8bbf5236f8e381d7f91cf99ed4b0978c50aee37cb9567cdeef65b7ec3d91b882852b1af'
  89. 'b8fe56e14006ab866970ddbd501c054ae37186ddc065bb869cf7d18db8c0d455118d5bda3255fb66a0dde38b544655cfe9040ffe46e41d19830b47959b2fb168'
  90. 'fac53c8ce68e9f56c8930a9392c89377c909f6a43a318010194949def91a104f34f46c2b32457e571435a8b326c47a48737ceb6255644bb6d42c59b27b07449a'
  91. '722d92b750f0a5af39b850c18ff0c57dac0165e3c0219415843ec5207945971448790fec3fca570b62c8726c89b0ca6b7a5b16fd503e4581b3a63b3adfcf2c50')
  92. sha512sums_i686=('3a346ff5e0fdefafd28bc3dd0e4b6cd68e3f0014e59d1611d99f2edb8d074fd32649eeb0894a7e340e4f907b5cfc0e08e0753e0427a68dc113bb22835a892968')
  93. sha512sums_armv7h=('a4aa00ca3f03d524d3fb6379116c4e4e7908e7c30f6347f55be256c44d806d8db5f04c96369d5a725e45b7390e9fde842f388cdc5d5699d80ec5d1519f7367f4'
  94. 'SKIP'
  95. 'b832287560c841e292d71be01c65045ee2ee6ac41f05176ebe349d730b5b79887bb629d176d5fd16a3e7ebb5e51de30b6d6fad6fad53821063188248bd1415bb'
  96. 'f997a0afaaffb66533168f5d9cc341871eb54feb88d6ce578e816add82596bedf4dc242510e171e1e5b56464cf701384a32ed916176ea0c2db24209d754d3c58'
  97. '96b97f6e721d179d88e7b4084ebb62ce30ddd13cbbcb367147e6646c8487107af36b3610d10e53abffae3a83736cdd7734e5dbcadb1909ced278f40a20302861'
  98. '14f3ef9f2211e98198e96bd4f91978720acd703ee778698b85916cef73c1aea648d1d08a075f2ed334f5c27b9933274fa0651401e0baa3570f389a20aaec54e8'
  99. 'b464e9af459c37c929ba30cdb7eb575038e970c9d91ff98fa37c0bc6161538b42a802dde34882772cf665130038158cb985fe06d65313f7c584c6c63045199d8'
  100. '9d8019b8f525d5614d476ac34a35a40e8e1994f444a686b561c57b8ae488fcc44ffca9d034cea7b2271a2b7a7fa3a2ba2fcaa452504c320eff0bc3fc4de64ed2'
  101. 'b3cf13c44b8b35bb7610206161a251cbf90299b0533e8e23465b9ae566feed510c5722aceadb7e2097de439362d0689de5692a091cbe8bec2994ef5290622095'
  102. '463d68de99f434fd3409ee620eaa7b648d6627c5a04cfeab65b91053129e71bf906db817fd9770297ae1e38f8a5a84be4d20a1d1717e6821478f2c1bbc416cb2'
  103. '813fbfb17659e4e7512367f03b06f9bc54070886f5e7206548deced60032f92d3ca0beb78416706662bf713cb0f7a5d8d81f8f08b911ca8254b417e82306d829'
  104. '7bda2ad7eb81af802873cb6764cb9c675ec50ceeb5adc487881ebc8c316cf55f836e56c2cc67494a2920e86494861db2eb924b7ff9b151ae3c5b0e493c373bf9')
  105. _replacesarchkernel=("${_replacesarchkernel[@]/\%/${pkgbase#linux-libre}}")
  106. _replacesoldkernels=("${_replacesoldkernels[@]/\%/${pkgbase#linux-libre}}")
  107. _replacesoldmodules=("${_replacesoldmodules[@]/\%/${pkgbase#linux-libre}}")
  108. case "$CARCH" in
  109. i686|x86_64) KARCH=x86;;
  110. armv7h) KARCH=arm;;
  111. esac
  112. export KBUILD_BUILD_HOST=parabola
  113. export KBUILD_BUILD_USER=$pkgbase
  114. export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
  115. prepare() {
  116. cd $_srcname
  117. if [ "${_srcname##*-}" != "$pkgver" ]; then
  118. echo "Applying upstream patch..."
  119. patch -Np1 < "../patch-${_srcname##*-}-gnu-$pkgver-gnu"
  120. fi
  121. echo "Adding freedo as boot logo..."
  122. install -m644 -t drivers/video/logo \
  123. ../logo_linux_{clut224.ppm,vga16.ppm,mono.pbm}
  124. echo "Setting version..."
  125. scripts/setlocalversion --save-scmversion
  126. echo "-$pkgrel" > localversion.10-pkgrel
  127. echo "${pkgbase#linux-libre}" > localversion.20-pkgname
  128. if [ "$CARCH" = "armv7h" ]; then
  129. local src_armv7h
  130. for src_armv7h in "${source_armv7h[@]}"; do
  131. src_armv7h="${src_armv7h%%::*}"
  132. src_armv7h="${src_armv7h##*/}"
  133. [[ $src_armv7h = *.patch ]] || continue
  134. echo "Applying patch $src_armv7h..."
  135. patch -Np1 < "../$src_armv7h"
  136. done
  137. fi
  138. if [ "$CARCH" = "i686" ]; then
  139. local src_i686
  140. for src_i686 in "${source_i686[@]}"; do
  141. src_i686="${src_i686%%::*}"
  142. src_i686="${src_i686##*/}"
  143. [[ $src_i686 = *.patch ]] || continue
  144. echo "Applying patch $src_i686..."
  145. patch -Np1 < "../$src_i686"
  146. done
  147. fi
  148. local src
  149. for src in "${source[@]}"; do
  150. src="${src%%::*}"
  151. src="${src##*/}"
  152. [[ $src = *.patch ]] || continue
  153. echo "Applying patch $src..."
  154. patch -Np1 < "../$src"
  155. done
  156. echo "Setting config..."
  157. cp ../config.$CARCH .config
  158. make olddefconfig
  159. make -s kernelrelease > version
  160. echo "Prepared $pkgbase version $(<version)"
  161. }
  162. build() {
  163. cd $_srcname
  164. make all
  165. make htmldocs
  166. }
  167. _package() {
  168. pkgdesc="The $pkgdesc kernel and modules"
  169. depends=(coreutils kmod initramfs)
  170. optdepends=('crda: to set the correct wireless channels of your country'
  171. 'linux-libre-firmware: firmware images needed for some devices')
  172. provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
  173. replaces=(virtualbox-guest-modules-arch wireguard-arch)
  174. provides+=("${_replacesarchkernel[@]/%/=$pkgver}" "LINUX-ABI_VERSION=$pkgver")
  175. conflicts+=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
  176. replaces+=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
  177. cd $_srcname
  178. local kernver="$(<version)"
  179. local modulesdir="$pkgdir/usr/lib/modules/$kernver"
  180. echo "Installing boot image..."
  181. # systemd expects to find the kernel here to allow hibernation
  182. # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
  183. install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
  184. # Used by mkinitcpio to name the kernel
  185. echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
  186. echo "Installing modules..."
  187. make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
  188. # remove build and source links
  189. rm "$modulesdir"/{source,build}
  190. if [ "$CARCH" = "armv7h" ]; then
  191. echo "Installing device tree binaries..."
  192. make INSTALL_DTBS_PATH="$pkgdir/boot/dtbs/$pkgbase" dtbs_install
  193. # armv7h presets only work with ALL_kver=$kernver
  194. backup=("etc/mkinitcpio.d/$pkgbase.preset")
  195. echo "Installing mkinitcpio preset..."
  196. sed "s|%PKGBASE%|$pkgbase|g;s|%KERNVER%|$kernver|g" ../linux-armv7h.preset \
  197. | install -Dm644 /dev/stdin "$pkgdir/etc/mkinitcpio.d/$pkgbase.preset"
  198. fi
  199. }
  200. _package-headers() {
  201. pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
  202. depends=(pahole)
  203. provides=("${_replacesarchkernel[@]/%/-headers=$pkgver}")
  204. conflicts=("${_replacesarchkernel[@]/%/-headers}" "${_replacesoldkernels[@]/%/-headers}")
  205. replaces=("${_replacesarchkernel[@]/%/-headers}" "${_replacesoldkernels[@]/%/-headers}")
  206. cd $_srcname
  207. local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
  208. echo "Installing build files..."
  209. install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
  210. localversion.* version vmlinux
  211. install -Dt "$builddir/kernel" -m644 kernel/Makefile
  212. install -Dt "$builddir/arch/$KARCH" -m644 arch/$KARCH/Makefile
  213. if [[ $CARCH = i686 ]]; then
  214. install -Dt "$builddir/arch/$KARCH" -m644 arch/$KARCH/Makefile_32.cpu
  215. fi
  216. cp -t "$builddir" -a scripts
  217. # add objtool for external module building and enabled VALIDATION_STACK option
  218. if [[ -e tools/objtool/objtool ]]; then
  219. install -Dt "$builddir/tools/objtool" tools/objtool/objtool
  220. fi
  221. # add xfs and shmem for aufs building
  222. mkdir -p "$builddir"/{fs/xfs,mm}
  223. echo "Installing headers..."
  224. cp -t "$builddir" -a include
  225. cp -t "$builddir/arch/$KARCH" -a arch/$KARCH/include
  226. install -Dt "$builddir/arch/$KARCH/kernel" -m644 arch/$KARCH/kernel/asm-offsets.s
  227. # from linux-armv7
  228. if [ "$CARCH" = "armv7h" ]; then
  229. for i in dove omap2; do
  230. mkdir -p "$builddir/arch/$KARCH/mach-$i"
  231. cp -t "$builddir/arch/$KARCH/mach-$i/" -a arch/$KARCH/mach-$i/include
  232. done
  233. for i in omap orion versatile; do
  234. mkdir -p "$builddir/arch/$KARCH/plat-$i"
  235. cp -t "$builddir/arch/$KARCH/plat-$i/" -a arch/$KARCH/plat-$i/include
  236. done
  237. fi
  238. install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
  239. install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
  240. # https://bugs.archlinux.org/task/13146
  241. install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
  242. # https://bugs.archlinux.org/task/20402
  243. install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
  244. install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
  245. install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
  246. # https://bugs.archlinux.org/task/71392
  247. install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
  248. echo "Installing KConfig files..."
  249. find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
  250. echo "Removing unneeded architectures..."
  251. local arch
  252. for arch in "$builddir"/arch/*/; do
  253. [[ $arch = */$KARCH/ ]] && continue
  254. echo "Removing $(basename "$arch")"
  255. rm -r "$arch"
  256. done
  257. echo "Removing documentation..."
  258. rm -r "$builddir/Documentation"
  259. echo "Removing broken symlinks..."
  260. find -L "$builddir" -type l -printf 'Removing %P\n' -delete
  261. echo "Removing loose objects..."
  262. find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
  263. echo "Stripping build tools..."
  264. local file
  265. while read -rd '' file; do
  266. case "$(file -bi "$file")" in
  267. application/x-sharedlib\;*) # Libraries (.so)
  268. strip -v $STRIP_SHARED "$file" ;;
  269. application/x-archive\;*) # Libraries (.a)
  270. strip -v $STRIP_STATIC "$file" ;;
  271. application/x-executable\;*) # Binaries
  272. strip -v $STRIP_BINARIES "$file" ;;
  273. application/x-pie-executable\;*) # Relocatable binaries
  274. strip -v $STRIP_SHARED "$file" ;;
  275. esac
  276. done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
  277. echo "Stripping vmlinux..."
  278. strip -v $STRIP_STATIC "$builddir/vmlinux"
  279. echo "Adding symlink..."
  280. mkdir -p "$pkgdir/usr/src"
  281. ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
  282. }
  283. _package-docs() {
  284. pkgdesc="Documentation for the $pkgdesc kernel"
  285. provides=("${_replacesarchkernel[@]/%/-docs=$pkgver}")
  286. conflicts=("${_replacesarchkernel[@]/%/-docs}" "${_replacesoldkernels[@]/%/-docs}")
  287. replaces=("${_replacesarchkernel[@]/%/-docs}" "${_replacesoldkernels[@]/%/-docs}")
  288. cd $_srcname
  289. local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
  290. echo "Installing documentation..."
  291. local src dst
  292. while read -rd '' src; do
  293. dst="${src#Documentation/}"
  294. dst="$builddir/Documentation/${dst#output/}"
  295. install -Dm644 "$src" "$dst"
  296. done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
  297. echo "Adding symlink..."
  298. mkdir -p "$pkgdir/usr/share/doc"
  299. ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
  300. }
  301. _package-chromebook() {
  302. pkgdesc="$pkgdesc kernel sign for Veyron Chromebooks"
  303. depends=(linux-libre=$pkgver)
  304. provides=("${_replacesarchkernel[@]/%/-armv7-chromebook=$pkgver}")
  305. conflicts=("${_replacesarchkernel[@]/%/-armv7-chromebook}" "${_replacesoldkernels[@]/%/-armv7-chromebook}")
  306. replaces=("${_replacesarchkernel[@]/%/-armv7-chromebook}" "${_replacesoldkernels[@]/%/-armv7-chromebook}")
  307. install=$pkgbase-chromebook.install
  308. cd $_srcname
  309. cp ../kernel.its .
  310. mkimage -D "-I dts -O dtb -p 2048" -f kernel.its kernel.signed
  311. dd if=/dev/zero of=bootloader.bin bs=512 count=1
  312. echo 'console=tty0 init=/sbin/init root=PARTUUID=%U/PARTNROFF=1 rootwait rw noinitrd' > cmdline
  313. echo "Creating kernel sign..."
  314. vbutil_kernel \
  315. --pack vmlinux.kpart \
  316. --version 1 \
  317. --vmlinuz kernel.signed \
  318. --arch arm \
  319. --keyblock ../kernel.keyblock \
  320. --signprivate ../kernel_data_key.vbprivk \
  321. --config cmdline \
  322. --bootloader bootloader.bin
  323. echo "Installing kernel sign..."
  324. mkdir -p "$pkgdir/boot"
  325. cp vmlinux.kpart "$pkgdir/boot"
  326. }
  327. pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
  328. [[ $CARCH = armv7h ]] && pkgname+=("$pkgbase-chromebook")
  329. for _p in "${pkgname[@]}"; do
  330. eval "package_$_p() {
  331. $(declare -f "_package${_p#$pkgbase}")
  332. _package${_p#$pkgbase}
  333. }"
  334. done
  335. # vim:set ts=8 sts=2 sw=2 et: