PKGBUILD 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. # Maintainer: Luke Shumaker <lukeshu@parabola.nu>
  2. # Contributor: Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
  3. # Contributor: fauno <fauno@kiwwwi.com.ar>
  4. # Contributor: Márcio Silva <coadde@hyperbola.info>
  5. pkgbase=libretools
  6. pkgname=(libretools librelib gitget)
  7. pkgdesc="Programs for Parabola development"
  8. url="https://git.parabola.nu/packages/libretools.git/"
  9. license=('GPL3' 'GPL2')
  10. pkgver=20181004
  11. source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz{,.sig}
  12. 0001-libremakepkg-rw-startdir.patch
  13. 0002-libremakepkg-pacman_5_2.patch)
  14. sha256sums=('2bdefd1803ba3e6cbd1eb955fad3de9ce8a4abfd23a0bd96a60772762df7b53b'
  15. 'SKIP'
  16. '19ed0fd21c9c789dd336b63b22094c45363b6ac5d7d1ab0eecd852d7f00d1883'
  17. '8986adf14a81b979b2ff4c4e3e76483115c146782e4ba30640649299f98355df')
  18. validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9') # Luke Shumaker
  19. pkgrel=6.2
  20. arch=('any')
  21. makedepends=(ruby-ronn)
  22. checkdepends=(
  23. bash-bats git
  24. 'pacman>=5.1.1-1.parabola5' 'pacman<6.1'
  25. expac
  26. openssh
  27. rsync
  28. tokyocabinet
  29. )
  30. prepare() {
  31. cd "$srcdir/$pkgbase-$pkgver"
  32. patch -N -p1 -i $srcdir/0001-libremakepkg-rw-startdir.patch
  33. patch -N -p1 -i $srcdir/0002-libremakepkg-pacman_5_2.patch
  34. }
  35. build() {
  36. cd "$srcdir/$pkgbase-$pkgver"
  37. make
  38. }
  39. check() {
  40. cd "$srcdir/$pkgbase-$pkgver"
  41. # FIXME as soon as possible
  42. # we needed to unbreak kernel builds, but tests were failing
  43. # with the stock PKGBUILD like this:
  44. # | not ok 13 libreblacklist works with everything set
  45. # | # (in test file cases/lib-blacklist.bats, line 15)
  46. # | # `v="$(libreblacklist get-rep <<<"$line")"; [[ $v == 'libre/linux-libre' ]]' failed
  47. # | # gpg: Warning: using insecure memory!
  48. # | # gpg: key 57169AAE979EC3AB marked as ultimately trusted
  49. # | # gpg: Warning: using insecure memory!
  50. # | # OK closing connection
  51. # SUDO_USER= make check TESTENVFLAGS='--no-network --no-sudo'
  52. }
  53. package_librelib() {
  54. pkgdesc="The shell library portion of libretools"
  55. license=(GPL2)
  56. conflicts=('xbs')
  57. optdepends=(
  58. 'libretools: for libreblacklist/blacklist.sh'
  59. 'wget: for libreblacklist/blacklist.sh'
  60. )
  61. cd "$srcdir/$pkgbase-$pkgver"
  62. make install-librelib DESTDIR="$pkgdir"
  63. }
  64. package_gitget() {
  65. pkgdesc="A simple to use downloader for git URLs"
  66. license=(GPL2)
  67. depends=("librelib=$pkgver" git)
  68. provides=("libregit=$pkgver")
  69. conflicts=("libregit")
  70. replaces=("libregit")
  71. cd "$srcdir/$pkgbase-$pkgver"
  72. make install-gitget DESTDIR="$pkgdir"
  73. }
  74. package_libretools() {
  75. backup=(etc/libretools.conf
  76. etc/libretools.d/chroot.conf
  77. etc/libretools.d/libredbdiff.conf
  78. etc/libretools.d/librefetch.conf)
  79. install=libretools.install
  80. conflicts=(devtools libretools-mips64el)
  81. replaces=(libretools-mips64el)
  82. depends=(
  83. "librelib=$pkgver"
  84. "gitget=$pkgver" # `createworkdir`
  85. 'pacman>=5.1.1-1.parabola5' 'pacman<6.1'
  86. arch-install-scripts # `mkarchroot` uses `pacstrap`
  87. binutils # `libremakepkg` uses `makepkg` uses `strip`
  88. expac # `libredbdiff`
  89. fakeroot # `libremakepkg` uses `makepkg` uses `fakeroot`
  90. make # `librefetch`
  91. openssh # `librerelease`
  92. rsync # `librerelease` and `makechrootpkg.sh`
  93. 'systemd-tools>=234' # systemd-nspawn
  94. tokyocabinet # `toru`
  95. #namcap # Namcap is currently dissabled in libremakepkg :-(
  96. subversion # `diff-unfree`
  97. wget # `aur`, optdepend for librelib:`blacklist`
  98. )
  99. optdepends=(
  100. 'qemu-user-static-binfmt: To build ARM packages from x86'
  101. )
  102. cd "$srcdir/$pkgbase-$pkgver"
  103. make install-libretools DESTDIR="$pkgdir"
  104. }