PKGBUILD 892 B

12345678910111213141516171819202122232425262728293031
  1. # Maintainer: Parabola Project <dev@lists.parabola.nu>
  2. pkgname=your-initfreedom
  3. pkgdesc="This package conflicts with every package known to work only for/with systemd."
  4. license=('GPL3')
  5. url="https://git.parabola.nu/blacklist.git"
  6. pkgver=20210628
  7. _gitver=50cf92a24fa5e2a6e4d70b90fbabd161dc2554e3
  8. pkgrel=1
  9. arch=('any')
  10. install=${pkgname}.install
  11. makedepends=(librelib)
  12. source=(blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_gitver})
  13. sha512sums=('b0a421a21eedde392d77d1b2264e7d71f4725e89481bca7a01afb25e95a51edeb10a4e7f5fadd31bd243cfdfcdb40d32215f497c994d938c5907223ef8ce9e28')
  14. package() {
  15. cd "$srcdir"
  16. conflicts=($( \
  17. < blacklist-${_gitver}.txt \
  18. libreblacklist normalize | \
  19. cut -d: -f1,2 | \
  20. sed -n 's/:$//p' | \
  21. sort -u \
  22. ))
  23. install -Dm644 blacklist-${_gitver}.txt "$pkgdir"/usr/share/doc/${pkgname}/blacklist.txt
  24. }