PKGBUILD 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Maintainer: (Arch) David Runge <dave@sleepmap.de>
  2. # Contributor (Arch): speps <speps at aur dot archlinux dot org>
  3. # Contributor (Arch): Alexander Fehr <pizzapunk gmail com>
  4. # Contributor (Arch): dorphell <dorphell@archlinux.org>
  5. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  6. # Contributor: André Silva <emulatorman@hyperbola.info>
  7. # Contributor: Aditya Som <icarious@hacari.org>"
  8. # parabola changes and rationale:
  9. # - removed gmail support
  10. pkgname=sylpheed
  11. pkgver=3.7.0
  12. pkgrel=3.nonprism1
  13. pkgdesc="Lightweight and user-friendly e-mail client, without Gmail support"
  14. arch=('x86_64' 'i686' 'armv7h')
  15. url="https://sylpheed.sraoss.jp/en/"
  16. license=('GPL')
  17. depends=('compface' 'gpgme' 'gtkspell' 'libnsl')
  18. makedepends=('openssl')
  19. source=("https://sylpheed.sraoss.jp/$pkgname/v${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
  20. "Support-SNI-some-servers-imap.gmail.patch::https://sylpheed.sraoss.jp/redmine/attachments/download/145/v2-0001-libsylph-ssl.c-Support-SNI-some-servers-imap.gmai.patch"
  21. "nonprism.patch")
  22. sha256sums=('eb23e6bda2c02095dfb0130668cf7c75d1f256904e3a7337815b4da5cb72eb04'
  23. '2c622fa0d110d5745925d3a265d7dd953679d335f85a3ed3d1dcc699d9575d89'
  24. '1e68cc016d7a62b171bb306169b24130fe20bf3cdfe2ff67ecc95e10a623098d')
  25. prepare() {
  26. cd "$pkgname-$pkgver"
  27. # patch for enchant >= 2.1.3
  28. # https://www.archlinux.org/todo/enchant-221-rebuild/
  29. sed -i 's,enchant/,enchant-2/,g' src/compose.c
  30. sed -i 's/ enchant/ enchant-2/g' configure
  31. # https://sylpheed.sraoss.jp/redmine/issues/306
  32. patch -p1 < "$srcdir"/Support-SNI-some-servers-imap.gmail.patch
  33. # Remove Gmail support
  34. patch -Np1 -i "$srcdir/nonprism.patch"
  35. }
  36. build() {
  37. cd "$pkgname-$pkgver"
  38. ./configure --prefix=/usr \
  39. --enable-maintainer-mode \
  40. --enable-ldap
  41. make
  42. # Build Attachment-Tool Plug-in
  43. cd plugin/attachment_tool && make
  44. }
  45. package() {
  46. cd "$pkgname-$pkgver"
  47. make DESTDIR="$pkgdir/" LDFLAGS+="/usr/lib/enchant-2" install
  48. # Install Attachment-Tool Plug-in
  49. cd plugin/attachment_tool
  50. make DESTDIR="$pkgdir/" install-plugin
  51. }